Skip to content

← Actionable
Medium, CVSS 6.6

Craft CMS Potential Remote Code Execution via Twig SSTI

CVE-2025-57811GHSA-crcq-738g-pqvc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.8.7, 4.16.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 4.0.0-RC1, <= 4.16.5>= 5.0.0-RC1, <= 5.8.6
    Fixed in
    4.16.6, 5.8.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-57811: 0.94% estimated exploitation activity in the next 30 days; percentile 61.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Note that users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled for this to work, which is against Craft CMS' recommendations for any non-dev environment. https://craftcms.com/knowledge-base/securing-craft#set-allowAdminChanges-to-false-in-production Note: This is a follow-up to GHSA-f3cw-hg6r-chfv Users should update to the patched versions (4.16.6 and 5.8.7) to mitigate the issue. Resources: https://github.com/craftcms/cms/pull/17612

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-crcq-738g-pqvc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57811

Advisory: Craft CMS Potential Remote Code Execution via Twig SSTI
IDs: CVE-2025-57811, GHSA-crcq-738g-pqvc
Record: https://patchnext.com/advisories/cve-2025-57811 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.8.7, 4.16.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 4.0.0-RC1, <= 4.16.5; >= 5.0.0-RC1, <= 5.8.6; fixed in 4.16.6, 5.8.7

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-crcq-738g-pqvc (GitHub-reviewed advisory GHSA-crcq-738g-pqvc lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <=5.8.6)

Commands are suggestions: review each one before running it.

Loading voting…