Skip to content

← Actionable
High, CVSS 8.7amended

jsPDF Denial of Service (DoS)

CVE-2025-57810GHSA-8mvj-3j78-4qmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jspdf 3.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jspdf

    Affected
    <= 3.0.1
    Fixed in
    3.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-57810: 0.69% estimated exploitation activity in the next 30 days; percentile 52.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact User control of the first argument of the addImage method results in CPU utilization and denial of service. If given the possibility to pass unsanitized image data or URLs to the addImage method, a user can provide a harmful PNG file that results in high CPU utilization and denial of service. Other affected methods are: html. Example payload: Patches The vulnerability was fixed in jsPDF 3.0.2. Upgrade to jspdf@=3.0.2. In jspdf@=3.0.2, invalid PNG files throw an Error instead of causing very long running loops. Workarounds Sanitize image data or URLs before passing it to the addImage method or one of the other affected methods. Credits Researcher: Aleksey Solovev (Positive Technologies)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8mvj-3j78-4qmw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8mvj-3j78-4qmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57810

Advisory: jsPDF Denial of Service (DoS)
IDs: CVE-2025-57810, GHSA-8mvj-3j78-4qmw
Record: https://patchnext.com/advisories/cve-2025-57810 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jspdf 3.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jspdf: affected <= 3.0.1; fixed in 3.0.2

## Suggested inspection (read-only)
- `npm ls jspdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jspdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8mvj-3j78-4qmw (OSV record GHSA-8mvj-3j78-4qmw lists affected ranges: npm jspdf >=0 <3.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-8mvj-3j78-4qmw (GitHub-reviewed advisory GHSA-8mvj-3j78-4qmw lists affected ranges: npm jspdf >=0 <=3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…