ImageMagick BlobStream Forward-Seek Under-Allocation
CVE-2025-57807GHSA-23hg-53q6-hqfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magick.net-q8-arm64 14.8.2; magick.net-q16-openmp-x64 14.8.2; magick.net-q16-hdri-openmp-arm64 14.8.2; magick.net-q16-hdri-arm64 14.8.2; magick.net-q8-openmp-x64 14.8.2; 7 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet magick.net-q8-arm64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-openmp-x64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-hdri-openmp-arm64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-hdri-arm64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q8-openmp-x64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-hdri-openmp-x64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-openmp-arm64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-x64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q8-x64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q8-openmp-arm64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-arm64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
NuGet magick.net-q16-hdri-x64
- Affected
- < 14.8.2
- Fixed in
- 14.8.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-23hg-53q6-hqfg lists affected ranges: NuGet magick.net-q16-x64 >=0 =0 =0 =0 =0 =0 =0 =0 =0 =0 <14.8.2;…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.8 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2025-57807: 0.29% estimated exploitation activity in the next 30 days; percentile 21.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Reporter: Lumina Mescuwa Product: ImageMagick 7 (MagickCore) Component: MagickCore/blob.c (Blob I/O - BlobStream) Tested: 7.1.2-0 (source tag) and 7.1.2-1 (Homebrew), macOS arm64, clang-17, Q16-HDRI Impact: Heap out-of-bounds WRITE (attacker-controlled bytes at attacker-chosen offset) → memory corruption; potential code execution --- Executive Summary For memory-backed blobs (BlobStream), SeekBlob() permits advancing the stream offset beyond the current end without increasing capacity. The subsequent WriteBlob() then expands by quantum + length (amortized) instead of offset + length, and copies to data + offset. When offset ≫ extent, the copy targets memory beyond the allocation, producing a deterministic heap write on 64-bit builds. No 2⁶⁴ arithmetic wrap, external delegates, or policy settings are required. --- Affected Scope - Versions confirmed: 7.1.2-0, 7.1.2-1 - Architectures: Observed on macOS arm64; architecture-agnostic on LP64 - Paths: MagickCore blob subsystem — BlobStream…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-23hg-53q6-hqfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57807 Advisory: ImageMagick BlobStream Forward-Seek Under-Allocation IDs: CVE-2025-57807, GHSA-23hg-53q6-hqfg Record: https://patchnext.com/advisories/cve-2025-57807 (revision 1, source checked 26 Oct 2026, 17:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: magick.net-q8-arm64 14.8.2; magick.net-q16-openmp-x64 14.8.2; magick.net-q16-hdri-openmp-arm64 14.8.2; magick.net-q16-hdri-arm64 14.8.2; magick.net-q8-openmp-x64 14.8.2; magick.net-q16-hdri-openmp-x64 14.8.2; magick.net-q16-openmp-arm64 14.8.2; magick.net-q16-x64 14.8.2; magick.net-q8-x64 14.8.2; magick.net-q8-openmp-arm64 14.8.2; magick.net-q16-arm64 14.8.2; magick.net-q16-hdri-x64 14.8.2. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet magick.net-q8-arm64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-openmp-x64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-hdri-openmp-arm64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-hdri-arm64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q8-openmp-x64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-hdri-openmp-x64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-openmp-arm64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-x64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q8-x64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q8-openmp-arm64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-arm64: affected < 14.8.2; fixed in 14.8.2 - NuGet magick.net-q16-hdri-x64: affected < 14.8.2; fixed in 14.8.2 ## Suggested inspection (read-only) - NuGet magick.net-q8-arm64: check the installed version with your package manager. - NuGet magick.net-q16-openmp-x64: check the installed version with your package manager. - NuGet magick.net-q16-hdri-openmp-arm64: check the installed version with your package manager. - NuGet magick.net-q16-hdri-arm64: check the installed version with your package manager. - NuGet magick.net-q8-openmp-x64: check the installed version with your package manager. - NuGet magick.net-q16-hdri-openmp-x64: check the installed version with your package manager. - NuGet magick.net-q16-openmp-arm64: check the installed version with your package manager. - NuGet magick.net-q16-x64: check the installed version with your package manager. - NuGet magick.net-q8-x64: check the installed version with your package manager. - NuGet magick.net-q8-openmp-arm64: check the installed version with your package manager. - NuGet magick.net-q16-arm64: check the installed version with your package manager. - NuGet magick.net-q16-hdri-x64: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magick.net-q8-arm64, magick.net-q16-openmp-x64, magick.net-q16-hdri-openmp-arm64, magick.net-q16-hdri-arm64, magick.net-q8-openmp-x64, magick.net-q16-hdri-openmp-x64, magick.net-q16-openmp-arm64, magick.net-q16-x64, magick.net-q8-x64, magick.net-q8-openmp-arm64, magick.net-q16-arm64, magick.net-q16-hdri-x64. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-23hg-53q6-hqfg (GitHub-reviewed advisory GHSA-23hg-53q6-hqfg lists affected ranges: NuGet magick.net-q16-x64 >=0 =0 =0 =0 =0 =0 =0 =0 =0 =0 <14.8.2;…) Commands are suggestions: review each one before running it.
Loading voting…