Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation (Post-RCE)
CVE-2025-57760GHSA-4gv9-mp8m-592r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow-base 0.5.1; langflow 1.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow-base
- Affected
- <= 0.5.0
- Fixed in
- 0.5.1
PyPI langflow
- Affected
- <= 1.5.0
- Fixed in
- 1.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4gv9-mp8m-592r lists affected ranges: PyPI langflow >=0 =0 <0.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gv9-mp8m-592r lists affected ranges: PyPI langflow >=0 =0 <=0.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-57760: 0.54% estimated exploitation activity in the next 30 days; percentile 45.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This vulnerability was discovered by researchers at Check Point. We are sharing this report as part of a responsible disclosure process and are happy to assist in validation and remediation if needed. Summary A privilege escalation vulnerability exists in Langflow containers where an authenticated user with RCE access can invoke the internal CLI command langflow superuser to create a new administrative user. This results in full superuser access, even if the user initially registered through the UI as a regular (non-admin) account. Details Langflow's Docker image includes a CLI binary at /app/.venv/bin/langflow that exposes sensitive commands, including: langflow superuser This command allows creation of a new superuser without checking whether one already exists. When combined with code execution (e.g., via the authenticated /api/v1/validate/code endpoint), a low-privileged user can execute: /app/.venv/bin/langflow superuser inside the container, and elevate themselves to full…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4gv9-mp8m-592r
- Revision 1 · created ·
Published from osv record GHSA-4gv9-mp8m-592r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57760 Advisory: Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation (Post-RCE) IDs: CVE-2025-57760, GHSA-4gv9-mp8m-592r Record: https://patchnext.com/advisories/cve-2025-57760 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow-base 0.5.1; langflow 1.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow-base: affected <= 0.5.0; fixed in 0.5.1 - PyPI langflow: affected <= 1.5.0; fixed in 1.5.1 ## Suggested inspection (read-only) - `python -m pip show langflow-base`: prints the installed version. Run with the environment that serves production active. - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow-base, langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4gv9-mp8m-592r (OSV record GHSA-4gv9-mp8m-592r lists affected ranges: PyPI langflow >=0 =0 <0.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-4gv9-mp8m-592r (GitHub-reviewed advisory GHSA-4gv9-mp8m-592r lists affected ranges: PyPI langflow >=0 =0 <=0.5.0) Commands are suggestions: review each one before running it.
Loading voting…