Skip to content

← Actionable
Medium, CVSS 4.3

Contao applies improper access control in the back end voters

CVE-2025-57758GHSA-7m47-r75r-cx8v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 5.6.1, 5.3.38; contao/core-bundle 5.6.1, 5.3.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/contao

    Affected
    >= 5.0.0, < 5.3.38>= 5.4.0-RC1, < 5.6.1
    Fixed in
    5.3.38, 5.6.1
  • Packagist contao/core-bundle

    Affected
    >= 5.0.0, < 5.3.38>= 5.4.0-RC1, < 5.6.1
    Fixed in
    5.3.38, 5.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-57758: 0.26% estimated exploitation activity in the next 30 days; percentile 17.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The table access voter in the back end doesn't check if a user is allowed to access the corresponding module. Patches Update to Contao 5.3.38 or 5.6.1. Workarounds Do not rely solely on the voter and additionally check USERCANACCESSMODULE. For more information If you have any questions or comments about this advisory, open an issue in contao/contao.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7m47-r75r-cx8v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57758

Advisory: Contao applies improper access control in the back end voters
IDs: CVE-2025-57758, GHSA-7m47-r75r-cx8v
Record: https://patchnext.com/advisories/cve-2025-57758 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/contao 5.6.1, 5.3.38; contao/core-bundle 5.6.1, 5.3.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/contao: affected >= 5.0.0, < 5.3.38; >= 5.4.0-RC1, < 5.6.1; fixed in 5.3.38, 5.6.1
- Packagist contao/core-bundle: affected >= 5.0.0, < 5.3.38; >= 5.4.0-RC1, < 5.6.1; fixed in 5.3.38, 5.6.1

## Suggested inspection (read-only)
- Packagist contao/contao: check the installed version with your package manager.
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/contao, contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7m47-r75r-cx8v (GitHub-reviewed advisory GHSA-7m47-r75r-cx8v lists affected ranges: Packagist contao/core-bundle >=5.0.0 =5.4.0-RC1 =5.0.0 =5.4.0-RC1 <5.6.1)

Commands are suggestions: review each one before running it.

Loading voting…