vite-plugin-static-copy files not included in src are possible to access with a crafted request
CVE-2025-57753GHSA-pp7p-q8fx-2968
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite-plugin-static-copy 3.1.2, 2.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.0.0, <= 3.1.1>= 0.4.3, <= 2.3.1
- Fixed in
- 3.1.2, 2.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pp7p-q8fx-2968 lists affected ranges: npm vite-plugin-static-copy >=3.0.0 =0.4.3 <2.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pp7p-q8fx-2968 lists affected ranges: npm vite-plugin-static-copy >=3.0.0 =0.4.3 <=2.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-57753: 0.42% estimated exploitation activity in the next 30 days; percentile 36.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Files not included in src was possible to access with a crafted request. Impact Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. Arbitrary files can be disclosed by exploiting this vulnerability. Details Consider the following configuration in used by vite.config.ts: The files under the ./public/images is only expected to be served. Abusing this vulnerability, an attacker can access arbitrary files on the filesystem. PoC I've attached a demo app to showcase the bug. Run it with npm run dev and issue the following HTTP request OR Observe that the /etc/passwd file is included in the response. <img width="1289" height="449" alt="Screenshot 2025-08-16 at 10 27 11 PM" src="https://github.com/user-attachments/assets/4de12612-7b86-44d7-a403-c76f12832e37" /
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pp7p-q8fx-2968
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pp7p-q8fx-2968
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57753 Advisory: vite-plugin-static-copy files not included in `src` are possible to access with a crafted request IDs: CVE-2025-57753, GHSA-pp7p-q8fx-2968 Record: https://patchnext.com/advisories/cve-2025-57753 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite-plugin-static-copy 3.1.2, 2.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite-plugin-static-copy: affected >= 3.0.0, <= 3.1.1; >= 0.4.3, <= 2.3.1; fixed in 3.1.2, 2.3.2 ## Suggested inspection (read-only) - `npm ls vite-plugin-static-copy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite-plugin-static-copy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pp7p-q8fx-2968 (OSV record GHSA-pp7p-q8fx-2968 lists affected ranges: npm vite-plugin-static-copy >=3.0.0 =0.4.3 <2.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pp7p-q8fx-2968 (GitHub-reviewed advisory GHSA-pp7p-q8fx-2968 lists affected ranges: npm vite-plugin-static-copy >=3.0.0 =0.4.3 <=2.3.1) Commands are suggestions: review each one before running it.
Loading voting…