Skip to content

← Actionable
High, CVSS 7.7amended

Denial-of-Service attack in pyLoad CNL Blueprint using dukpy.evaljs

CVE-2025-57751GHSA-9gjj-6gj7-c4wj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev92), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyload-ng

    Affected
    < 0.5.0b3.dev92
    Fixed in
    0.5.0b3.dev92

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-57751: 0.33% estimated exploitation activity in the next 30 days; percentile 25.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Dear Maintainers, I am writing to you on behalf of the Tencent AI Sec. We have identified a potential vulnerability in one of your products and would like to report it to you for further investigation and mitigation. Summary The jk parameter is received in pyLoad CNL Blueprint. Due to the lack of jk parameter verification, the jk parameter input by the user is directly determined as dykpy.evaljs(), resulting in the server CPU being fully occupied and the web-ui becoming unresponsive. Details - Endpoint: flash/addcrypted2 - affected file: https://github.com/pyload/pyload/blob/develop/src/pyload/webui/app/blueprints/cnlblueprint.py#L123 https://github.com/pyload/pyload/blob/develop/src/pyload/core/utils/misc.py#L42 affected code PoC download pyload and run locally, send the following request - PoC The 30000 can be modified to any large value. Impact System resources are exhausted, causing services to be temporarily interrupted or stopped, making them inaccessible to normal users. Use…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9gjj-6gj7-c4wj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9gjj-6gj7-c4wj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57751

Advisory: Denial-of-Service attack in pyLoad CNL Blueprint using dukpy.evaljs
IDs: CVE-2025-57751, GHSA-9gjj-6gj7-c4wj
Record: https://patchnext.com/advisories/cve-2025-57751 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev92. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyload-ng: affected < 0.5.0b3.dev92; fixed in 0.5.0b3.dev92

## Suggested inspection (read-only)
- `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyload-ng.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9gjj-6gj7-c4wj (OSV record GHSA-9gjj-6gj7-c4wj lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev92 (fixed))
- Verified: https://github.com/advisories/GHSA-9gjj-6gj7-c4wj (GitHub-reviewed advisory GHSA-9gjj-6gj7-c4wj lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev92)

Commands are suggestions: review each one before running it.

Loading voting…