n8n symlink traversal vulnerability in "Read/Write File" node allows access to restricted files
CVE-2025-57749GHSA-ggjm-f3g4-rwmm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.106.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.106.0
- Fixed in
- 1.106.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ggjm-f3g4-rwmm lists affected ranges: npm n8n >=0 <1.106.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ggjm-f3g4-rwmm lists affected ranges: npm n8n >=0 <1.106.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-57749: 0.49% estimated exploitation activity in the next 30 days; percentile 42.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A symlink traversal vulnerability was discovered in the Read/Write File node in n8n. While the node attempts to restrict access to sensitive directories and files, it does not properly account for symbolic links (symlinks). An attacker with the ability to create symlinks—such as by using the Execute Command node—could exploit this to bypass the intended directory restrictions and read from or write to otherwise inaccessible paths. Users of n8n.cloud are not impacted. Patches Affected users should update to version 1.106.0 or later. Workarounds Until the patch is applied: - Disable or restrict access to the Execute Command node and any other nodes that allow arbitrary file system access. - Avoid using the Read/Write File node on untrusted paths or inputs that could be manipulated via symlinks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-ggjm-f3g4-rwmm
- Revision 1 · created ·
Published from osv record GHSA-ggjm-f3g4-rwmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57749 Advisory: n8n symlink traversal vulnerability in "Read/Write File" node allows access to restricted files IDs: CVE-2025-57749, GHSA-ggjm-f3g4-rwmm Record: https://patchnext.com/advisories/cve-2025-57749 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 1.106.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.106.0; fixed in 1.106.0 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ggjm-f3g4-rwmm (OSV record GHSA-ggjm-f3g4-rwmm lists affected ranges: npm n8n >=0 <1.106.0 (fixed)) - Verified: https://github.com/advisories/GHSA-ggjm-f3g4-rwmm (GitHub-reviewed advisory GHSA-ggjm-f3g4-rwmm lists affected ranges: npm n8n >=0 <1.106.0) Commands are suggestions: review each one before running it.
Loading voting…