GP247 and S-Cart have a stored cross-site scripting (XSS) vulnerability
CVE-2025-57407GHSA-46v4-5mc8-q2cf
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist gp247/core
- Affected
- < 1.1.24
- Fixed in
- 1.1.24
Packagist s-cart/core
- Affected
- <= 9.0.5
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-46v4-5mc8-q2cf lists affected ranges: Packagist s-cart/core >=0 =0 <1.1.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2025-57407: 0.22% estimated exploitation activity in the next 30 days; percentile 12.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart <=10.0.3 allows a remote authenticated attacker to inject arbitrary web script or HTML via a crafted User-Agent header. The script is executed in an administrator's browser when they view the security log page, which could lead to session hijacking or other malicious actions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-46v4-5mc8-q2cf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57407 Advisory: GP247 and S-Cart have a stored cross-site scripting (XSS) vulnerability IDs: CVE-2025-57407, GHSA-46v4-5mc8-q2cf Record: https://patchnext.com/advisories/cve-2025-57407 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: gp247/core 1.1.24. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist gp247/core: affected < 1.1.24; fixed in 1.1.24 - Packagist s-cart/core: affected <= 9.0.5 ## Suggested inspection (read-only) - Packagist gp247/core: check the installed version with your package manager. - Packagist s-cart/core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gp247/core, s-cart/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-46v4-5mc8-q2cf (GitHub-reviewed advisory GHSA-46v4-5mc8-q2cf lists affected ranges: Packagist s-cart/core >=0 =0 <1.1.24) Commands are suggestions: review each one before running it.
Loading voting…