messageformat prototype pollution vulnerability
CVE-2025-57353GHSA-6xv4-9cqp-92rh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@messageformat/runtime 3.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.0.1, <= 3.0.1
- Fixed in
- 3.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6xv4-9cqp-92rh lists affected ranges: npm @messageformat/runtime >=3.0.1 <3.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6xv4-9cqp-92rh lists affected ranges: npm @messageformat/runtime >=3.0.1 <=3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-57353: 0.34% estimated exploitation activity in the next 30 days; percentile 27.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Runtime components of messageformat package for Node.js version 3.0.1 contain a prototype pollution vulnerability. Due to insufficient validation of nested message keys during the processing of message data, an attacker can manipulate the prototype chain of JavaScript objects by providing specially crafted input. This can result in the injection of arbitrary properties into the Object.prototype, potentially leading to denial of service conditions or unexpected application behavior. The vulnerability allows attackers to alter the prototype of base objects, impacting all subsequent object instances throughout the application's lifecycle. Version 3.0.2 contains a fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6xv4-9cqp-92rh
- Revision 1 · created ·
Published from osv record GHSA-6xv4-9cqp-92rh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-57353 Advisory: messageformat prototype pollution vulnerability IDs: CVE-2025-57353, GHSA-6xv4-9cqp-92rh Record: https://patchnext.com/advisories/cve-2025-57353 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @messageformat/runtime 3.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @messageformat/runtime: affected >= 3.0.1, <= 3.0.1; fixed in 3.0.2 ## Suggested inspection (read-only) - `npm ls @messageformat/runtime --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @messageformat/runtime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6xv4-9cqp-92rh (OSV record GHSA-6xv4-9cqp-92rh lists affected ranges: npm @messageformat/runtime >=3.0.1 <3.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-6xv4-9cqp-92rh (GitHub-reviewed advisory GHSA-6xv4-9cqp-92rh lists affected ranges: npm @messageformat/runtime >=3.0.1 <=3.0.1) Commands are suggestions: review each one before running it.
Loading voting…