Skip to content

← Actionable
Medium, CVSS 6.5amended

parse is vulnerable to prototype pollution

CVE-2025-57324GHSA-9g8m-v378-pcg3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse 7.0.0-alpha.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm parse

    Affected
    < 7.0.0-alpha.1
    Fixed in
    7.0.0-alpha.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-57324: 0.36% estimated exploitation activity in the next 30 days; percentile 29.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

parse is a package designed to parse JavaScript SDK. A Prototype Pollution vulnerability in the SingleInstanceStateController.initializeState function of parse allows attackers to inject properties on Object.prototype via supplying a crafted payload, causing denial of service (DoS) as the minimum consequence.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9g8m-v378-pcg3

  2. Revision 1 · created ·

    Published from osv record GHSA-9g8m-v378-pcg3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-57324

Advisory: parse is vulnerable to prototype pollution
IDs: CVE-2025-57324, GHSA-9g8m-v378-pcg3
Record: https://patchnext.com/advisories/cve-2025-57324 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse 7.0.0-alpha.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm parse: affected < 7.0.0-alpha.1; fixed in 7.0.0-alpha.1

## Suggested inspection (read-only)
- `npm ls parse --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9g8m-v378-pcg3 (OSV record GHSA-9g8m-v378-pcg3 lists affected ranges: npm parse >=0 <7.0.0-alpha.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9g8m-v378-pcg3 (GitHub-reviewed advisory GHSA-9g8m-v378-pcg3 lists affected ranges: npm parse >=0 <7.0.0-alpha.1)

Commands are suggestions: review each one before running it.

Loading voting…