Skip to content

← Actionable
Medium, CVSS 6.4

New authd users logging in via SSH are members of the root group

CVE-2025-5689GHSA-g8qw-mgjx-rwjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ubuntu/authd 0.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-5689: 0.30% estimated exploitation activity in the next 30 days; percentile 22.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When an authd user logs in via SSH for the first time (meaning they do not yet exist in the authd user database) and successfully authenticates via the configured broker, the user is considered a member of the root group in the context of that SSH session. This situation may allow the user to read and write files that are accessible by the root group, to which they should not have access. The user does not get root privileges or any capabilities beyond the access granted to the root group. Preconditions under which this vulnerability affects a system authd was installed via the PPA. An OAuth 2.0 application was registered in Microsoft Entra ID or Google IAM, and the respective authd broker was installed (authd-msentraid or authd-google) and configured. sshd was configured to enable SSH access with authd, i.e.: The username is allowed by the sshallowedsuffixes option in the broker configuriation. The user is allowed by the allowedusers option in the broker configuration. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g8qw-mgjx-rwjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-5689

Advisory: New authd users logging in via SSH are members of the root group
IDs: CVE-2025-5689, GHSA-g8qw-mgjx-rwjr
Record: https://patchnext.com/advisories/cve-2025-5689 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ubuntu/authd 0.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ubuntu/authd: affected < 0.5.4; fixed in 0.5.4

## Suggested inspection (read-only)
- Go github.com/ubuntu/authd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ubuntu/authd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g8qw-mgjx-rwjr (GitHub-reviewed advisory GHSA-g8qw-mgjx-rwjr lists affected ranges: Go github.com/ubuntu/authd >=0 <0.5.4)

Commands are suggestions: review each one before running it.

Loading voting…