@farmfe/core is Missing Origin Validation in WebSocket
CVE-2025-56647GHSA-p773-8mf4-rjm5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@farmfe/core 1.7.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @farmfe/core
- Affected
- < 1.7.6
- Fixed in
- 1.7.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p773-8mf4-rjm5 lists affected ranges: npm @farmfe/core >=0 <1.7.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p773-8mf4-rjm5 lists affected ranges: npm @farmfe/core >=0 <1.7.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-56647: 0.22% estimated exploitation activity in the next 30 days; percentile 12.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
npm @farmfe/core before 1.7.6 is Missing Origin Validation in WebSocket. The development (hot module reloading) server does not validate origin when connecting to a WebSocket client. This allows attackers to surveil developers running Farm who visit their webpage and steal source code that is leaked by the WebSocket server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p773-8mf4-rjm5
- Revision 1 · created ·
Published from osv record GHSA-p773-8mf4-rjm5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-56647 Advisory: @farmfe/core is Missing Origin Validation in WebSocket IDs: CVE-2025-56647, GHSA-p773-8mf4-rjm5 Record: https://patchnext.com/advisories/cve-2025-56647 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @farmfe/core 1.7.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @farmfe/core: affected < 1.7.6; fixed in 1.7.6 ## Suggested inspection (read-only) - `npm ls @farmfe/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @farmfe/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p773-8mf4-rjm5 (OSV record GHSA-p773-8mf4-rjm5 lists affected ranges: npm @farmfe/core >=0 <1.7.6 (fixed)) - Verified: https://github.com/advisories/GHSA-p773-8mf4-rjm5 (GitHub-reviewed advisory GHSA-p773-8mf4-rjm5 lists affected ranges: npm @farmfe/core >=0 <1.7.6) Commands are suggestions: review each one before running it.
Loading voting…