LimeSurvey is vulnerable to SQL injection
CVE-2025-56421GHSA-rccq-2fxq-7x3h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (limesurvey/limesurvey 6.15.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist limesurvey/limesurvey
- Affected
- < 6.15.4
- Fixed in
- 6.15.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rccq-2fxq-7x3h lists affected ranges: Packagist limesurvey/limesurvey >=0 <6.15.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2025-56421: 0.50% estimated exploitation activity in the next 30 days; percentile 42.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SQL Injection vulnerability in LimeSurvey before v.6.15.4+250710 allows a remote attacker to obtain sensitive information from the database.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rccq-2fxq-7x3h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-56421 Advisory: LimeSurvey is vulnerable to SQL injection IDs: CVE-2025-56421, GHSA-rccq-2fxq-7x3h Record: https://patchnext.com/advisories/cve-2025-56421 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: limesurvey/limesurvey 6.15.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist limesurvey/limesurvey: affected < 6.15.4; fixed in 6.15.4 ## Suggested inspection (read-only) - Packagist limesurvey/limesurvey: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on limesurvey/limesurvey. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rccq-2fxq-7x3h (GitHub-reviewed advisory GHSA-rccq-2fxq-7x3h lists affected ranges: Packagist limesurvey/limesurvey >=0 <6.15.4) Commands are suggestions: review each one before running it.
Loading voting…