Skip to content

← Actionable
Medium, CVSS 6.1amended

validator.js has a URL validation bypass vulnerability in its isURL function

CVE-2025-56200GHSA-9965-vmph-33xx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (validator 13.15.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm validator

    Affected
    < 13.15.20
    Fixed in
    13.15.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-56200: 0.32% estimated exploitation activity in the next 30 days; percentile 25.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A URL validation bypass vulnerability exists in validator.js prior to version 13.15.20. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9965-vmph-33xx

  2. Revision 1 · created ·

    Published from osv record GHSA-9965-vmph-33xx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-56200

Advisory: validator.js has a URL validation bypass vulnerability in its isURL function
IDs: CVE-2025-56200, GHSA-9965-vmph-33xx
Record: https://patchnext.com/advisories/cve-2025-56200 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: validator 13.15.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm validator: affected < 13.15.20; fixed in 13.15.20

## Suggested inspection (read-only)
- `npm ls validator --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on validator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9965-vmph-33xx (OSV record GHSA-9965-vmph-33xx lists affected ranges: npm validator >=0 <13.15.20 (fixed))
- Verified: https://github.com/advisories/GHSA-9965-vmph-33xx (GitHub-reviewed advisory GHSA-9965-vmph-33xx lists affected ranges: npm validator >=0 <13.15.20)

Commands are suggestions: review each one before running it.

Loading voting…