Skip to content

← Actionable
Low, CVSS 2.1

Apache Tomcat Vulnerable to Improper Neutralization of Escape, Meta, or Control Sequences

CVE-2025-55754GHSA-vfww-5hm6-hx2j

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-catalina

    Affected
    >= 11.0.0-M1, < 11.0.11>= 10.1.0-M1, < 10.1.45>= 8.5.60, <= 8.5.100>= 9.0.40, < 9.0.109
    Fixed in
    9.0.109, 11.0.11, 10.1.45
  • Maven org.apache.tomcat.embed:tomcat-embed-core

    Affected
    >= 11.0.0-M1, < 11.0.11>= 10.1.0-M1, < 10.1.45>= 8.5.60, <= 8.5.100>= 9.0.40, < 9.0.109
    Fixed in
    9.0.109, 11.0.11, 10.1.45
  • Maven org.apache.tomcat:tomcat

    Affected
    >= 11.0.0-M1, < 11.0.11>= 10.1.0-M1, < 10.1.45>= 8.5.60, <= 8.5.100>= 9.0.40, < 9.0.109
    Fixed in
    9.0.109, 11.0.11, 10.1.45

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-vfww-5hm6-hx2j lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =8.5.60 =9.0.40 =11.0.0-M1 =10.1.0-M1 =8.5.60 =9.0.40 =11.0.0-M1 =10.1.0-M1 =8.5.60 =9.0.40 <9.0.109

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-55754: 10.17% estimated exploitation activity in the next 30 days; percentile 95.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vfww-5hm6-hx2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55754

Advisory: Apache Tomcat Vulnerable to Improper Neutralization of Escape, Meta, or Control Sequences
IDs: CVE-2025-55754, GHSA-vfww-5hm6-hx2j
Record: https://patchnext.com/advisories/cve-2025-55754 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.11, 10.1.45, 9.0.109; org.apache.tomcat.embed:tomcat-embed-core 11.0.11, 10.1.45, 9.0.109; org.apache.tomcat:tomcat 11.0.11, 10.1.45, 9.0.109. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.11; >= 10.1.0-M1, < 10.1.45; >= 8.5.60, <= 8.5.100; >= 9.0.40, < 9.0.109; fixed in 9.0.109, 11.0.11, 10.1.45
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.11; >= 10.1.0-M1, < 10.1.45; >= 8.5.60, <= 8.5.100; >= 9.0.40, < 9.0.109; fixed in 9.0.109, 11.0.11, 10.1.45
- Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.11; >= 10.1.0-M1, < 10.1.45; >= 8.5.60, <= 8.5.100; >= 9.0.40, < 9.0.109; fixed in 9.0.109, 11.0.11, 10.1.45

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vfww-5hm6-hx2j (GitHub-reviewed advisory GHSA-vfww-5hm6-hx2j lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =8.5.60 =9.0.40 =11.0.0-M1 =10.1.0-M1 =8.5.60 =9.0.40 =11.0.0-M1 =10.1.0-M1 =8.5.60 =9.0.40 <9.0.109)

Commands are suggestions: review each one before running it.

Loading voting…