Skip to content

← Actionable
High, CVSS 7.7

Apache Tomcat Vulnerable to Relative Path Traversal

CVE-2025-55752GHSA-wmwf-9ccg-fff5

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-catalina

    Affected
    >= 11.0.0-M1, < 11.0.11>= 10.1.0-M1, < 10.1.45>= 9.0.0-M11, < 9.0.109>= 8.5.6, <= 8.5.100
    Fixed in
    9.0.109, 11.0.11, 10.1.45
  • Maven org.apache.tomcat.embed:tomcat-embed-core

    Affected
    >= 11.0.0-M1, < 11.0.11>= 10.1.0-M1, < 10.1.45>= 9.0.0-M11, < 9.0.109>= 8.5.6, <= 8.5.100
    Fixed in
    9.0.109, 11.0.11, 10.1.45
  • Maven org.apache.tomcat:tomcat

    Affected
    >= 11.0.0-M1, < 11.0.11>= 10.1.0-M1, < 10.1.45>= 9.0.0-M11, < 9.0.109>= 8.5.6, <= 8.5.100
    Fixed in
    9.0.109, 11.0.11, 10.1.45

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-wmwf-9ccg-fff5 lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.0-M11 =8.5.6 =11.0.0-M1 =10.1.0-M1 =9.0.0-M11 =8.5.6 =11.0.0-M1 =10.1.0-M1 =9.0.0-M11 =8.5.6 <=8.5.100

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-55752: 64.41% estimated exploitation activity in the next 30 days; percentile 99.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wmwf-9ccg-fff5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55752

Advisory: Apache Tomcat Vulnerable to Relative Path Traversal
IDs: CVE-2025-55752, GHSA-wmwf-9ccg-fff5
Record: https://patchnext.com/advisories/cve-2025-55752 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.11, 10.1.45, 9.0.109; org.apache.tomcat.embed:tomcat-embed-core 11.0.11, 10.1.45, 9.0.109; org.apache.tomcat:tomcat 11.0.11, 10.1.45, 9.0.109. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.11; >= 10.1.0-M1, < 10.1.45; >= 9.0.0-M11, < 9.0.109; >= 8.5.6, <= 8.5.100; fixed in 9.0.109, 11.0.11, 10.1.45
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.11; >= 10.1.0-M1, < 10.1.45; >= 9.0.0-M11, < 9.0.109; >= 8.5.6, <= 8.5.100; fixed in 9.0.109, 11.0.11, 10.1.45
- Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.11; >= 10.1.0-M1, < 10.1.45; >= 9.0.0-M11, < 9.0.109; >= 8.5.6, <= 8.5.100; fixed in 9.0.109, 11.0.11, 10.1.45

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wmwf-9ccg-fff5 (GitHub-reviewed advisory GHSA-wmwf-9ccg-fff5 lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.0-M11 =8.5.6 =11.0.0-M1 =10.1.0-M1 =9.0.0-M11 =8.5.6 =11.0.0-M1 =10.1.0-M1 =9.0.0-M11 =8.5.6 <=8.5.100)

Commands are suggestions: review each one before running it.

Loading voting…