Skip to content

← Actionable
Critical, CVSS 9.3amended

Directus allows unauthenticated file upload and file modification due to lacking input sanitization

CVE-2025-55746GHSA-mv33-9f6j-pfmc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.9.3; @directus/api 28.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 10.8.0, < 11.9.3
    Fixed in
    11.9.3
  • npm @directus/api

    Affected
    >= 14.1.0, < 28.0.2
    Fixed in
    28.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:L
EPSS
  • CVE-2025-55746: 1.40% estimated exploitation activity in the next 30 days; percentile 72.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability exists in the file update mechanism which allows an unauthenticated actor to modify existing files with arbitrary contents (without changes being applied to the files' database-resident metadata) and / or upload new files, with arbitrary content and extensions, which won't show up in the Directus UI. Details Directus exposes the CRUD operations for uploading or handling files under the /files route. The endpoint handler is responsible for updating an existing file identified by the provided primary key specified through the pk parameter. Primary keys are UUID values such as /files/927b3abf-fb4b-4c66-bdaa-eb7dc48a51cb. Here the filenamedisk value is never sanitized, it's possible to pass a path containing traversal sequences (../) through it, but a fully arbitrary file write is not possible in case the "local" storage handler is used. (Other storage implementations haven't been checked during the research process). The packages/storage-driver-local/src/index.ts…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mv33-9f6j-pfmc

  2. Revision 1 · created ·

    Published from osv record GHSA-mv33-9f6j-pfmc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55746

Advisory: Directus allows unauthenticated file upload and file modification due to lacking input sanitization
IDs: CVE-2025-55746, GHSA-mv33-9f6j-pfmc
Record: https://patchnext.com/advisories/cve-2025-55746 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.9.3; @directus/api 28.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 10.8.0, < 11.9.3; fixed in 11.9.3
- npm @directus/api: affected >= 14.1.0, < 28.0.2; fixed in 28.0.2

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @directus/api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus, @directus/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mv33-9f6j-pfmc (OSV record GHSA-mv33-9f6j-pfmc lists affected ranges: npm directus >=10.8.0 =14.1.0 <28.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-mv33-9f6j-pfmc (GitHub-reviewed advisory GHSA-mv33-9f6j-pfmc lists affected ranges: npm directus >=10.8.0 =14.1.0 <28.0.2)

Commands are suggestions: review each one before running it.

Loading voting…