Skip to content

← Actionable
Low, CVSS 2.5

UnoPim has CSV Injection on Quick Export feature

CVE-2025-55745GHSA-74rg-6f92-g6wx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unopim/unopim 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P · score source
EPSS
  • CVE-2025-55745: 0.63% estimated exploitation activity in the next 30 days; percentile 50.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Description: CSV Injection or Formula Injection is a security vulnerability that occurs when malicious content is inserted into a CSV (Comma-Separated Values) file, which is then opened in a spreadsheet application like Microsoft Excel. This attack exploits the way spreadsheet software automatically interprets certain text patterns as formulas or commands, rather than plain text. Details A basic test for CSV Injection is using SUM() to add two numbers or open calc.exe​ using​ command: =cmd|' /C calc'!A0​ The same method can be used to run arbitrary code on the victim's machine. For example the below code will download and execute a malicious script to create a reverse TCP connection to the attacker's machine. Payload: This is our payload and will be used in the vulnerable field during exploitation shell.ps1: PoC: 1. Go to any product and click on Edit 2. Add the above discussed payload in any field that accept text for e.g. Product Number field. 3. Quick Export - Select CSV,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-74rg-6f92-g6wx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55745

Advisory: UnoPim has CSV Injection on Quick Export feature
IDs: CVE-2025-55745, GHSA-74rg-6f92-g6wx
Record: https://patchnext.com/advisories/cve-2025-55745 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unopim/unopim 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist unopim/unopim: affected <= 0.3.0; fixed in 0.3.1

## Suggested inspection (read-only)
- Packagist unopim/unopim: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unopim/unopim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-74rg-6f92-g6wx (GitHub-reviewed advisory GHSA-74rg-6f92-g6wx lists affected ranges: Packagist unopim/unopim >=0 <=0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…