Skip to content

← Actionable
High, CVSS 7.3

UnoPim vulnerable to remote code execution through Arbitrary File upload

CVE-2025-55743GHSA-v22v-xwh7-2vrm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unopim/unopim 0.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-55743: 0.48% estimated exploitation activity in the next 30 days; percentile 41.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary: Affected Functionality: Image upload at User creation Endpoint: /admin/settings/users/create Details The image upload at the user creation feature performs only client side file type validation. A user can capture the request by uploading an image, capture the request through a Proxy like Burp suite. Make changes to the file extension and content. The .php file when accessed through the link runs the code we provided inside the file. Modified part of the multipart request body: PoC 1. Upload an image file as profile picture during user creation , now capture the request and modify. File content: File name: poc.php Content-Type can be any, doesn't matter. 2. Access the uploaded file e.g. http://localhost:8000/storage/admins/21/poc.php?cmd=ls // pass the command to run as parameter value for cmd, example running ls command on the system Likewise a reverse shell code ( reverse shell of other languages ) can be executed to create a connection to attacker controlled system.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v22v-xwh7-2vrm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55743

Advisory: UnoPim vulnerable to remote code execution through Arbitrary File upload
IDs: CVE-2025-55743, GHSA-v22v-xwh7-2vrm
Record: https://patchnext.com/advisories/cve-2025-55743 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unopim/unopim 0.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist unopim/unopim: affected <= 0.2.0; fixed in 0.2.1

## Suggested inspection (read-only)
- Packagist unopim/unopim: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unopim/unopim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v22v-xwh7-2vrm (GitHub-reviewed advisory GHSA-v22v-xwh7-2vrm lists affected ranges: Packagist unopim/unopim >=0 <=0.2.0)

Commands are suggestions: review each one before running it.

Loading voting…