Skip to content

← Actionable
Medium, CVSS 6.8

UnoPim has Stored Cross-site Scripting vulnerability in user creation functionality

CVE-2025-55742GHSA-xr97-25v7-hc2q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (unopim/unopim 0.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-55742: 0.39% estimated exploitation activity in the next 30 days; percentile 32.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Affected Functionality: User creation Endpoint: /admin/settings/users/create Details https://github.com/unopim/unopim/blob/a0dc81947a59ada69e19e1e4313dd591d4e277b4/packages/Webkul/Core/src/Traits/Sanitizer.php#L9-L19 See the mimetype is checked for validation. Mime-type is usually identified by analysing the first few bytes of the file content, which contains the File signature or Magic bytes for e.g. GIF file starts with GIF87a or GIF89a. We can mislead the sanitizer to think the uploaded file is gif ( based on magic byte provided ) while actually it is a .svg file. File containing <svg is considered as svg and is sanitized: Sanitization bypass using MIME type manipulation: PoC Upload POC.html as image. File content: I changed extension to .html because even though POC.svg successfully bypassed the sanitization. When accessing the URL, the page didn't render as it should starts with <. Since html doesn't have any such limitation we can access it. Access the image URL to see…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xr97-25v7-hc2q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55742

Advisory: UnoPim has Stored Cross-site Scripting vulnerability in user creation functionality
IDs: CVE-2025-55742, GHSA-xr97-25v7-hc2q
Record: https://patchnext.com/advisories/cve-2025-55742 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: unopim/unopim 0.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist unopim/unopim: affected <= 0.2.0; fixed in 0.2.1

## Suggested inspection (read-only)
- Packagist unopim/unopim: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on unopim/unopim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xr97-25v7-hc2q (GitHub-reviewed advisory GHSA-xr97-25v7-hc2q lists affected ranges: Packagist unopim/unopim >=0 <=0.2.0)

Commands are suggestions: review each one before running it.

Loading voting…