Skip to content

← Actionable
Low, CVSS 1.8amended

Exiv2 has quadratic performance in ICC profile parsing in JpegBase::readMetadata

CVE-2025-55304GHSA-m54q-mm9w-fp6g

What to do

Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI exiv2

    Affected
    <= 0.17.3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-55304: 0.25% estimated exploitation activity in the next 30 days; percentile 16.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial-of-service was found in Exiv2 version v0.28.5: a quadratic algorithm in the ICC profile parsing code in jpegBase::readMetadata() can cause Exiv2 to run for a long time. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted jpg image file. Patches The bug is fixed in version v0.28.6. References Issue: https://github.com/Exiv2/exiv2/issues/3333 Fixes: https://github.com/Exiv2/exiv2/pull/3335 (main branch), https://github.com/Exiv2/exiv2/pull/3345 (0.28.x branch) For more information Please see our security policy for information about Exiv2 security.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m54q-mm9w-fp6g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m54q-mm9w-fp6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55304

Advisory: Exiv2 has quadratic performance in ICC profile parsing in JpegBase::readMetadata
IDs: CVE-2025-55304, GHSA-m54q-mm9w-fp6g
Record: https://patchnext.com/advisories/cve-2025-55304 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI exiv2: affected <= 0.17.3

## Suggested inspection (read-only)
- `python -m pip show exiv2`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on exiv2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m54q-mm9w-fp6g (OSV record GHSA-m54q-mm9w-fp6g lists affected ranges: PyPI exiv2 >=0 <=0.17.3)
- Verified: https://github.com/advisories/GHSA-m54q-mm9w-fp6g (GitHub-reviewed advisory GHSA-m54q-mm9w-fp6g lists affected ranges: PyPI exiv2 >=0 <=0.17.3)

Commands are suggestions: review each one before running it.

Loading voting…