screenshot-desktop vulnerable to command Injection via format option
CVE-2025-55294GHSA-gjx4-2c7g-fm94
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (screenshot-desktop 1.15.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.15.2
- Fixed in
- 1.15.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gjx4-2c7g-fm94 lists affected ranges: npm screenshot-desktop >=0 <1.15.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gjx4-2c7g-fm94 lists affected ranges: npm screenshot-desktop >=0 <1.15.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-55294: 1.44% estimated exploitation activity in the next 30 days; percentile 73.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability is a command injection issue. When user-controlled input is passed into the format option of the screenshot function, it is interpolated into a shell command without sanitization. An attacker can craft malicious input such as: { format: "; echo vulnerable /tmp/hello;" } This results in arbitrary command execution with the privileges of the calling process. Who is impacted: Any application that accepts untrusted input and forwards it directly (or indirectly) into the format option is affected. If the library is used in a server-side context (e.g., API endpoints, web services), attackers may be able to exploit this remotely and without authentication, leading to full compromise of confidentiality, integrity, and availability. CVSS v3.1 Base Score: 9.8 (Critical) CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H Patches The issue has been patched in version 1.15.2. All users are strongly recommended to upgrade to 1.15.2 or later. All earlier versions are vulnerable.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gjx4-2c7g-fm94
- Revision 1 · created ·
Published from osv record GHSA-gjx4-2c7g-fm94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55294 Advisory: screenshot-desktop vulnerable to command Injection via `format` option IDs: CVE-2025-55294, GHSA-gjx4-2c7g-fm94 Record: https://patchnext.com/advisories/cve-2025-55294 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: screenshot-desktop 1.15.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm screenshot-desktop: affected < 1.15.2; fixed in 1.15.2 ## Suggested inspection (read-only) - `npm ls screenshot-desktop --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on screenshot-desktop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gjx4-2c7g-fm94 (OSV record GHSA-gjx4-2c7g-fm94 lists affected ranges: npm screenshot-desktop >=0 <1.15.2 (fixed)) - Verified: https://github.com/advisories/GHSA-gjx4-2c7g-fm94 (GitHub-reviewed advisory GHSA-gjx4-2c7g-fm94 lists affected ranges: npm screenshot-desktop >=0 <1.15.2) Commands are suggestions: review each one before running it.
Loading voting…