Skip to content

← Actionable
Low, CVSS 2.6amended

Template Secret leakage in logs in Scaffolder when using fetch:template

CVE-2025-55285GHSA-3x3q-ghcp-whf7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/plugin-scaffolder-backend 2.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-55285: 0.24% estimated exploitation activity in the next 30 days; percentile 15.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A logging flaw in Backstage Scaffolder’s fetch:template action up to @backstage/plugin-scaffolder-backend 2.1.0 may write template secrets to logs. The action emitted a duplicate, pre-redaction copy of input parameters, so values provided via the {{ secrets }} bag could appear in local/server logs when the action ran. Exploitation requires use of the secrets argument and access to Scaffolder/build logs; integrity and availability are unaffected. Fix: upgrade to 2.1.1, which removes the duplicate log path and ensures secrets are redacted. Mitigation: avoid passing {{ secrets }} to fetch:template if upgrade is not possible. Open an issue in the Backstage repository Visit our Discord, linked to in Backstage README

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3x3q-ghcp-whf7

  2. Revision 1 · created ·

    Published from osv record GHSA-3x3q-ghcp-whf7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55285

Advisory: Template Secret leakage in logs in Scaffolder when using `fetch:template`
IDs: CVE-2025-55285, GHSA-3x3q-ghcp-whf7
Record: https://patchnext.com/advisories/cve-2025-55285 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @backstage/plugin-scaffolder-backend 2.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @backstage/plugin-scaffolder-backend: affected <= 2.1.0; fixed in 2.1.1

## Suggested inspection (read-only)
- `npm ls @backstage/plugin-scaffolder-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @backstage/plugin-scaffolder-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3x3q-ghcp-whf7 (OSV record GHSA-3x3q-ghcp-whf7 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <2.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-3x3q-ghcp-whf7 (GitHub-reviewed advisory GHSA-3x3q-ghcp-whf7 lists affected ranges: npm @backstage/plugin-scaffolder-backend >=0 <=2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…