Claude Code's Permissive Default Allowlist Enables Unauthorized File Read and Network Exfiltration in Claude Code
CVE-2025-55284GHSA-x5gv-jw7f-j6xj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 1.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.4
- Fixed in
- 1.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x5gv-jw7f-j6xj lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x5gv-jw7f-j6xj lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-55284: 0.60% estimated exploitation activity in the next 30 days; percentile 48.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Due to an overly broad allowlist of safe commands, it was possible to bypass the Claude Code confirmation prompts to read a file and then send file contents over the network without user confirmation. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update received this fix automatically after release. Current users of Claude Code are unaffected, as versions prior to 1.0.24 are deprecated and have been forced to update. Thank you to https://hackerone.com/wunderwuzzi23 for reporting this issue!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x5gv-jw7f-j6xj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x5gv-jw7f-j6xj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55284 Advisory: Claude Code's Permissive Default Allowlist Enables Unauthorized File Read and Network Exfiltration in Claude Code IDs: CVE-2025-55284, GHSA-x5gv-jw7f-j6xj Record: https://patchnext.com/advisories/cve-2025-55284 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 1.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @anthropic-ai/claude-code: affected < 1.0.4; fixed in 1.0.4 ## Suggested inspection (read-only) - `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @anthropic-ai/claude-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x5gv-jw7f-j6xj (OSV record GHSA-x5gv-jw7f-j6xj lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-x5gv-jw7f-j6xj (GitHub-reviewed advisory GHSA-x5gv-jw7f-j6xj lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.4) Commands are suggestions: review each one before running it.
Loading voting…