Skip to content

← Actionable
Medium, CVSS 6.9amended

Copier's safe template has filesystem write access outside destination path

CVE-2025-55214GHSA-p7q8-grrj-3m8w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (copier 9.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI copier

    Affected
    >= 7.1.0, < 9.9.1
    Fixed in
    9.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-55214: 0.26% estimated exploitation activity in the next 30 days; percentile 18.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Copier suggests that it's safe to generate a project from a safe template, i.e. one that doesn't use unsafe features like custom Jinja extensions which would require passing the --UNSAFE,--trust flag. As it turns out, a safe template can currently write files outside the destination path where a project shall be generated or updated. This is possible when rendering a generated directory structure whose rendered path is either a relative parent path or an absolute path. Constructing such paths is possible using Copier's builtin pathjoin Jinja filter and its builtin copierconf.sep variable, which is the platform-native path separator. This way, a malicious template author can create a template that overwrites arbitrary files (according to the user's write permissions), e.g., to cause havoc. Write access via generated relative path Reproducible example: Write access via generated absolute path Reproducible example: - POSIX: - Windows (PowerShell): This scenario is slightly less…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p7q8-grrj-3m8w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-p7q8-grrj-3m8w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55214

Advisory: Copier's safe template has filesystem write access outside destination path
IDs: CVE-2025-55214, GHSA-p7q8-grrj-3m8w
Record: https://patchnext.com/advisories/cve-2025-55214 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: copier 9.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI copier: affected >= 7.1.0, < 9.9.1; fixed in 9.9.1

## Suggested inspection (read-only)
- `python -m pip show copier`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on copier.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p7q8-grrj-3m8w (OSV record GHSA-p7q8-grrj-3m8w lists affected ranges: PyPI copier >=7.1.0 <9.9.1 (fixed))
- Verified: https://github.com/advisories/GHSA-p7q8-grrj-3m8w (GitHub-reviewed advisory GHSA-p7q8-grrj-3m8w lists affected ranges: PyPI copier >=7.1.0 <9.9.1)

Commands are suggestions: review each one before running it.

Loading voting…