Skip to content

← Actionable
Medium, CVSS 5.8

OpenFGA Authorization Bypass

CVE-2025-55213GHSA-mgh9-4mwp-fg55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 1.9.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-55213: 0.32% estimated exploitation activity in the next 30 days; percentile 25.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. Am I Affected? You are affected by this vulnerability if you are using OpenFGA v1.9.3 to v1.9.4, specifically under the following preconditions: - Calling Check API or ListObjects with an authorization model that has a relationship directly assignable by more than 1 userset with same type, and - There are check or list object queries that rely on the above relationship, and - You have userset tuples that are assigned to the above relationship Fix Upgrade to v1.9.5. This upgrade is backwards compatible. Workaround Downgrade to v1.9.2 with enable-check-optimizations removed from OPENFGAEXPERIMENTALS Acknowledgments OpenFGA would like Dominic Harries and rrozza-apolitical to thank for discovering this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mgh9-4mwp-fg55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55213

Advisory: OpenFGA Authorization Bypass
IDs: CVE-2025-55213, GHSA-mgh9-4mwp-fg55
Record: https://patchnext.com/advisories/cve-2025-55213 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 1.9.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openfga/openfga: affected >= 1.9.3, < 1.9.5; fixed in 1.9.5

## Suggested inspection (read-only)
- Go github.com/openfga/openfga: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openfga/openfga.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mgh9-4mwp-fg55 (GitHub-reviewed advisory GHSA-mgh9-4mwp-fg55 lists affected ranges: Go github.com/openfga/openfga >=1.9.3 <1.9.5)

Commands are suggestions: review each one before running it.

Loading voting…