Skip to content

← Actionable
Low, CVSS 2.7

Opencast has a partial path traversal vulnerability in UI config

CVE-2025-55202GHSA-hq8m-v68g-8cf8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencastproject:opencast-user-interface-configuration 18.1, 17.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-55202: 0.40% estimated exploitation activity in the next 30 days; percentile 34.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The protections against path traversal attacks in the UI config module are insufficient, still partially allowing for attacks in very specific cases. The path is checked without checking for the file separator. This could allow attackers access to files within another folder which starts with the same path. For example, the default UI config directory is placed at /etc/opencast/ui-config. Without this patch, an attacker can get access to files in a folder /etc/opencast/ui-config-hidden if those files are readable by Opencast. General path traversal is not possible. For example, an attacker cannot exploit this to access files in /etc/opencast/encoding or even in /etc/opencast/ directly. How dangerous is this? Theoretically, this vulnerability may be exploited to get access to some non-public files. However, given the default structure of Opencast's configuration, this is extremely unlikely to hit any users. There can be but one ui-config folders. This makes it quite unlikely for any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hq8m-v68g-8cf8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55202

Advisory: Opencast has a partial path traversal vulnerability in UI config
IDs: CVE-2025-55202, GHSA-hq8m-v68g-8cf8
Record: https://patchnext.com/advisories/cve-2025-55202 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opencastproject:opencast-user-interface-configuration 18.1, 17.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opencastproject:opencast-user-interface-configuration: affected < 17.7; >= 18.0, <= 18.0; fixed in 18.1, 17.7

## Suggested inspection (read-only)
- Maven org.opencastproject:opencast-user-interface-configuration: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opencastproject:opencast-user-interface-configuration.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hq8m-v68g-8cf8 (GitHub-reviewed advisory GHSA-hq8m-v68g-8cf8 lists affected ranges: Maven org.opencastproject:opencast-user-interface-configuration >=0 =18.0 <=18.0)

Commands are suggestions: review each one before running it.

Loading voting…