Copier's safe template has arbitrary filesystem read/write access
CVE-2025-55201GHSA-3xw7-v6cj-5q8h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (copier 9.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI copier
- Affected
- < 9.9.1
- Fixed in
- 9.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3xw7-v6cj-5q8h lists affected ranges: PyPI copier >=0 <9.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3xw7-v6cj-5q8h lists affected ranges: PyPI copier >=0 <9.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-55201: 0.26% estimated exploitation activity in the next 30 days; percentile 17.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Copier's current security model shall restrict filesystem access through Jinja: - Files can only be read using {% include ... %}, which is limited by Jinja to reading files from the subtree of the local template clone in our case. - Files are written in the destination directory according to their counterparts in the template. Copier suggests that it's safe to generate a project from a safe template, i.e. one that doesn't use unsafe features like custom Jinja extensions which would require passing the --UNSAFE,--trust flag. As it turns out, a safe template can currently read and write arbitrary files because we expose a few pathlib.Path objects in the Jinja context which have unconstrained I/O methods. This effectively renders our security model w.r.t. filesystem access useless. Arbitrary read access Imagine, e.g., a malicious template author who creates a template that reads SSH keys or other secrets from well-known locations, perhaps "masks" them with Base64 encoding to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3xw7-v6cj-5q8h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3xw7-v6cj-5q8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55201 Advisory: Copier's safe template has arbitrary filesystem read/write access IDs: CVE-2025-55201, GHSA-3xw7-v6cj-5q8h Record: https://patchnext.com/advisories/cve-2025-55201 (revision 3, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: copier 9.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI copier: affected < 9.9.1; fixed in 9.9.1 ## Suggested inspection (read-only) - `python -m pip show copier`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on copier. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3xw7-v6cj-5q8h (OSV record GHSA-3xw7-v6cj-5q8h lists affected ranges: PyPI copier >=0 <9.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3xw7-v6cj-5q8h (GitHub-reviewed advisory GHSA-3xw7-v6cj-5q8h lists affected ranges: PyPI copier >=0 <9.9.1) Commands are suggestions: review each one before running it.
Loading voting…