Skip to content

← Actionable
Medium, CVSS 5.3amended

Source Code Exposure Vulnerability in React Server Components

CVE-2025-55183GHSA-925w-6v3x-g4j4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-server-dom-turbopack 19.2.2, 19.1.3, 19.0.2; react-server-dom-parcel 19.2.2, 19.1.3, 19.0.2; react-server-dom-webpack 19.2.2, 19.1.3, 19.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-server-dom-turbopack

    Affected
    >= 19.0.0, < 19.0.2>= 19.1.0, < 19.1.3>= 19.2.0, < 19.2.2
    Fixed in
    19.0.2, 19.2.2, 19.1.3
  • npm react-server-dom-parcel

    Affected
    >= 19.0.0, < 19.0.2>= 19.1.0, < 19.1.3>= 19.2.0, < 19.2.2
    Fixed in
    19.0.2, 19.2.2, 19.1.3
  • npm react-server-dom-webpack

    Affected
    >= 19.0.0, < 19.0.2>= 19.1.0, < 19.1.3>= 19.2.0, < 19.2.2
    Fixed in
    19.0.2, 19.2.2, 19.1.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-55183: 64.23% estimated exploitation activity in the next 30 days; percentile 99.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There is a source code exposure vulnerability in React Server Components. React recommends updating immediately. The vulnerability exists in versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1 of: - react-server-dom-webpack - react-server-dom-parcel - react-server-dom-turbopack These issues are present in the patches published last week. Patches Fixes were back ported to versions 19.0.2, 19.1.3, and 19.2.2. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability. References See the blog post for more information and upgrade instructions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-925w-6v3x-g4j4

  2. Revision 1 · created ·

    Published from osv record GHSA-925w-6v3x-g4j4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55183

Advisory: Source Code Exposure Vulnerability in React Server Components
IDs: CVE-2025-55183, GHSA-925w-6v3x-g4j4
Record: https://patchnext.com/advisories/cve-2025-55183 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-server-dom-turbopack 19.2.2, 19.1.3, 19.0.2; react-server-dom-parcel 19.2.2, 19.1.3, 19.0.2; react-server-dom-webpack 19.2.2, 19.1.3, 19.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-server-dom-turbopack: affected >= 19.0.0, < 19.0.2; >= 19.1.0, < 19.1.3; >= 19.2.0, < 19.2.2; fixed in 19.0.2, 19.2.2, 19.1.3
- npm react-server-dom-parcel: affected >= 19.0.0, < 19.0.2; >= 19.1.0, < 19.1.3; >= 19.2.0, < 19.2.2; fixed in 19.0.2, 19.2.2, 19.1.3
- npm react-server-dom-webpack: affected >= 19.0.0, < 19.0.2; >= 19.1.0, < 19.1.3; >= 19.2.0, < 19.2.2; fixed in 19.0.2, 19.2.2, 19.1.3

## Suggested inspection (read-only)
- `npm ls react-server-dom-turbopack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls react-server-dom-parcel --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls react-server-dom-webpack --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-server-dom-turbopack, react-server-dom-parcel, react-server-dom-webpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-925w-6v3x-g4j4 (OSV record GHSA-925w-6v3x-g4j4 lists affected ranges: npm react-server-dom-parcel >=19.0.0 =19.1.0 =19.2.0 =19.0.0 =19.1.0 =19.2.0 =19.0.0 =19.1.0 =19.2.0 <19.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-925w-6v3x-g4j4 (GitHub-reviewed advisory GHSA-925w-6v3x-g4j4 lists affected ranges: npm react-server-dom-parcel >=19.0.0 =19.1.0 =19.2.0 =19.0.0 =19.1.0 =19.2.0 =19.0.0 =19.1.0 =19.2.0 <19.2.2)

Commands are suggestions: review each one before running it.

Loading voting…