content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE
CVE-2025-55164GHSA-w2cq-g8g3-gm83
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (content-security-policy-parser 0.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm content-security-policy-parser
- Affected
- < 0.6.0
- Fixed in
- 0.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w2cq-g8g3-gm83 lists affected ranges: npm content-security-policy-parser >=0 <0.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w2cq-g8g3-gm83 lists affected ranges: npm content-security-policy-parser >=0 <0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-55164: 0.47% estimated exploitation activity in the next 30 days; percentile 40.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A prototype pollution vulnerability exists in versions 0.5.0 and earlier, wherein if you provide a policy name called proto you can override the Object prototype. For example: Outputs: Whilst no gadget exists in this library, it is possible via other libraries expose functionality that enable RCE. It is customary to label prototype pollution vulnerabilities in this way. The most common effect of this is denial of service, as you can trivially overwrite properties. As the content security policy is provided in HTTP queries, it is incredibly likely that network exploitation is possible. Patches There has been a patch implemented a year ago (11 Feb 2024), but low uptake of patched versions has not been observed in the wild - only 17% of weekly downloads are of patched versions. Workarounds By disabling prototype method in NodeJS you can neutralise all possible prototype pollution attacks. Provide either --disable-proto=delete (recommended) or --disable-proto=throw as an argument…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w2cq-g8g3-gm83
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w2cq-g8g3-gm83
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55164 Advisory: content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE IDs: CVE-2025-55164, GHSA-w2cq-g8g3-gm83 Record: https://patchnext.com/advisories/cve-2025-55164 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: content-security-policy-parser 0.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm content-security-policy-parser: affected < 0.6.0; fixed in 0.6.0 ## Suggested inspection (read-only) - `npm ls content-security-policy-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on content-security-policy-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w2cq-g8g3-gm83 (OSV record GHSA-w2cq-g8g3-gm83 lists affected ranges: npm content-security-policy-parser >=0 <0.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w2cq-g8g3-gm83 (GitHub-reviewed advisory GHSA-w2cq-g8g3-gm83 lists affected ranges: npm content-security-policy-parser >=0 <0.6.0) Commands are suggestions: review each one before running it.
Loading voting…