Mattermost allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL
CVE-2025-55073GHSA-ff85-qw3h-g9vp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20250929212932-a41db04d2746; github.com/mattermost/mattermost-server 10.12.1, 10.11.4, 10.5.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20250929212932-a41db04d2746
- Fixed in
- 8.0.0-20250929212932-a41db04d2746
Go github.com/mattermost/mattermost-server
- Affected
- >= 10.11.0, < 10.11.4>= 10.5.0, < 10.5.12>= 10.12.0, < 10.12.1
- Fixed in
- 10.11.4, 10.5.12, 10.12.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ff85-qw3h-g9vp lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0 =10.5.0 =10.12.0 =0 <8.0.0-20250929212932-a41db04d2746
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2025-55073: 0.20% estimated exploitation activity in the next 30 days; percentile 9.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ff85-qw3h-g9vp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55073 Advisory: Mattermost allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL IDs: CVE-2025-55073, GHSA-ff85-qw3h-g9vp Record: https://patchnext.com/advisories/cve-2025-55073 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250929212932-a41db04d2746; github.com/mattermost/mattermost-server 10.12.1, 10.11.4, 10.5.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250929212932-a41db04d2746; fixed in 8.0.0-20250929212932-a41db04d2746 - Go github.com/mattermost/mattermost-server: affected >= 10.11.0, < 10.11.4; >= 10.5.0, < 10.5.12; >= 10.12.0, < 10.12.1; fixed in 10.11.4, 10.5.12, 10.12.1 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ff85-qw3h-g9vp (GitHub-reviewed advisory GHSA-ff85-qw3h-g9vp lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0 =10.5.0 =10.12.0 =0 <8.0.0-20250929212932-a41db04d2746) Commands are suggestions: review each one before running it.
Loading voting…