Apache Spark has Inadequate Encryption Strength
CVE-2025-55039GHSA-6p6v-m64v-jx8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.spark:spark-network-common_2.13 3.5.2, 3.4.4; pyspark 3.5.2, 3.4.4; org.apache.spark:spark-network-common_2.12 3.5.2, 3.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-network-common_2.13
- Affected
- >= 3.5.0, < 3.5.2< 3.4.4
- Fixed in
- 3.4.4, 3.5.2
PyPI pyspark
- Affected
- < 3.4.4>= 3.5.0, < 3.5.2
- Fixed in
- 3.4.4, 3.5.2
Maven org.apache.spark:spark-network-common_2.12
- Affected
- < 3.4.4>= 3.5.0, < 3.5.2
- Fixed in
- 3.4.4, 3.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6p6v-m64v-jx8q lists affected ranges: Maven org.apache.spark:spark-network-common_2.13 >=3.5.0 =0 =0 =3.5.0 =0 =3.5.0 <3.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6p6v-m64v-jx8q lists affected ranges: Maven org.apache.spark:spark-network-common_2.13 >=3.5.0 =0 =0 =3.5.0 =0 =3.5.0 <3.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-55039: 0.21% estimated exploitation activity in the next 30 days; percentile 10.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This issue affects Apache Spark versions before 3.4.4, 3.5.2 and 4.0.0. Apache Spark versions before 4.0.0, 3.5.2 and 3.4.4 use an insecure default network encryption cipher for RPC communication between nodes. When spark.network.crypto.enabled is set to true (it is set to false by default), but spark.network.crypto.cipher is not explicitly configured, Spark defaults to AES in CTR mode (AES/CTR/NoPadding), which provides encryption without authentication. This vulnerability allows a man-in-the-middle attacker to modify encrypted RPC traffic undetected by flipping bits in ciphertext, potentially compromising heartbeat messages or application data and affecting the integrity of Spark workflows. To mitigate this issue, users should either configure spark.network.crypto.cipher to AES/GCM/NoPadding to enable authenticated encryption or enable SSL encryption by setting spark.ssl.enabled to true, which provides stronger transport security.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6p6v-m64v-jx8q
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6p6v-m64v-jx8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55039 Advisory: Apache Spark has Inadequate Encryption Strength IDs: CVE-2025-55039, GHSA-6p6v-m64v-jx8q Record: https://patchnext.com/advisories/cve-2025-55039 (revision 3, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.spark:spark-network-common_2.13 3.5.2, 3.4.4; pyspark 3.5.2, 3.4.4; org.apache.spark:spark-network-common_2.12 3.5.2, 3.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-network-common_2.13: affected >= 3.5.0, < 3.5.2; < 3.4.4; fixed in 3.4.4, 3.5.2 - PyPI pyspark: affected < 3.4.4; >= 3.5.0, < 3.5.2; fixed in 3.4.4, 3.5.2 - Maven org.apache.spark:spark-network-common_2.12: affected < 3.4.4; >= 3.5.0, < 3.5.2; fixed in 3.4.4, 3.5.2 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-network-common_2.13: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. - Maven org.apache.spark:spark-network-common_2.12: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-network-common_2.13, pyspark, org.apache.spark:spark-network-common_2.12. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6p6v-m64v-jx8q (OSV record GHSA-6p6v-m64v-jx8q lists affected ranges: Maven org.apache.spark:spark-network-common_2.13 >=3.5.0 =0 =0 =3.5.0 =0 =3.5.0 <3.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-6p6v-m64v-jx8q (GitHub-reviewed advisory GHSA-6p6v-m64v-jx8q lists affected ranges: Maven org.apache.spark:spark-network-common_2.13 >=3.5.0 =0 =0 =3.5.0 =0 =3.5.0 <3.5.2) Commands are suggestions: review each one before running it.
Loading voting…