The AuthKit Remix Library renders sensitive auth data in HTML
CVE-2025-55009GHSA-v3gr-w9gf-23cx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@workos-inc/authkit-remix 0.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.15.0
- Fixed in
- 0.15.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v3gr-w9gf-23cx lists affected ranges: npm @workos-inc/authkit-remix >=0 <0.15.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v3gr-w9gf-23cx lists affected ranges: npm @workos-inc/authkit-remix >=0 <0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
- EPSS
- CVE-2025-55009: 0.41% estimated exploitation activity in the next 30 days; percentile 35.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Before 0.15.0, @workos-inc/authkit-remix returned sensitive authentication artifacts from the authkitLoader, specifically sealedSession and accessToken. Because these values were returned from the loader, they were embedded into the server-rendered HTML and became readable by any script with access to the page’s DOM (e.g., in the presence of XSS or a malicious browser extension). Impact: Exposure of these secrets can lead to session hijacking and unauthorized API access. Fix: Version 0.15.0 changes the default behavior so the loader no longer returns sealedSession/accessToken. A secure server-side mechanism is provided to fetch an access token when needed. Patches Patched in v0.15.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v3gr-w9gf-23cx
- Revision 1 · created ·
Published from osv record GHSA-v3gr-w9gf-23cx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-55009 Advisory: The AuthKit Remix Library renders sensitive auth data in HTML IDs: CVE-2025-55009, GHSA-v3gr-w9gf-23cx Record: https://patchnext.com/advisories/cve-2025-55009 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @workos-inc/authkit-remix 0.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @workos-inc/authkit-remix: affected < 0.15.0; fixed in 0.15.0 ## Suggested inspection (read-only) - `npm ls @workos-inc/authkit-remix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @workos-inc/authkit-remix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v3gr-w9gf-23cx (OSV record GHSA-v3gr-w9gf-23cx lists affected ranges: npm @workos-inc/authkit-remix >=0 <0.15.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v3gr-w9gf-23cx (GitHub-reviewed advisory GHSA-v3gr-w9gf-23cx lists affected ranges: npm @workos-inc/authkit-remix >=0 <0.15.0) Commands are suggestions: review each one before running it.
Loading voting…