Skip to content

← Actionable
Medium, CVSS 5.3

OpenBao Userpass and LDAP User Lockout Bypass

CVE-2025-54998GHSA-j3xv-7fxp-gfhx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openbao/openbao 2.3.2, 0.0.0-20250807212521-c52795c1ef74), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/openbao/openbao

    Affected
    >= 0.1.0, < 2.3.2< 0.0.0-20250807212521-c52795c1ef74
    Fixed in
    0.0.0-20250807212521-c52795c1ef74, 2.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-54998: 0.23% estimated exploitation activity in the next 30 days; percentile 14.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Attackers could bypass the automatic user lockout mechanisms in the OpenBao Userpass or LDAP auth systems. This was caused by different aliasing between pre-flight and full login request user entity alias attributions. Patches OpenBao v2.3.2 will patch this issue. Workarounds Existing users may apply rate-limiting quotas on the authentication endpoints: https://openbao.org/api-docs/system/rate-limit-quotas/ References This issue was disclosed to HashiCorp and is the OpenBao equivalent of the following tickets: - https://discuss.hashicorp.com/t/hcsec-2025-16-vault-userpass-and-ldap-user-lockout-bypass/76035 - https://nvd.nist.gov/vuln/detail/CVE-2025-6004

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j3xv-7fxp-gfhx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54998

Advisory: OpenBao Userpass and LDAP User Lockout Bypass
IDs: CVE-2025-54998, GHSA-j3xv-7fxp-gfhx
Record: https://patchnext.com/advisories/cve-2025-54998 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openbao/openbao 2.3.2, 0.0.0-20250807212521-c52795c1ef74. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openbao/openbao: affected >= 0.1.0, < 2.3.2; < 0.0.0-20250807212521-c52795c1ef74; fixed in 0.0.0-20250807212521-c52795c1ef74, 2.3.2

## Suggested inspection (read-only)
- Go github.com/openbao/openbao: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openbao/openbao.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j3xv-7fxp-gfhx (GitHub-reviewed advisory GHSA-j3xv-7fxp-gfhx lists affected ranges: Go github.com/openbao/openbao >=0.1.0 =0 <0.0.0-20250807212521-c52795c1ef74)

Commands are suggestions: review each one before running it.

Loading voting…