Privileged OpenBao Operator May Execute Code on the Underlying Host
CVE-2025-54997GHSA-xp75-r577-cvhp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openbao/openbao 2.3.2, 0.0.0-20250806194004-a14053c9679d), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.1.0, < 2.3.2< 0.0.0-20250806194004-a14053c9679d
- Fixed in
- 2.3.2, 0.0.0-20250806194004-a14053c9679d
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xp75-r577-cvhp lists affected ranges: Go github.com/openbao/openbao >=0.1.0 =0 <0.0.0-20250806194004-a14053c9679d
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-54997: 0.43% estimated exploitation activity in the next 30 days; percentile 37.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Under certain threat models, OpenBao operators with privileged API access may not be system administrators and thus normally lack the ability to update binaries or execute code on the system. Additionally, privileged API operators should be unable to perform TCP connections to arbitrary hosts in the environment OpenBao is executing within. The API-driven audit subsystem granted privileged API operators the ability to do both with an attacker-controlled log prefix. Access to these endpoints should be restricted. Patches OpenBao v2.3.2 will patch this issue. Workarounds Users may deny all access to the sys/audit/ interface (with create and update) permission via policies with explicit deny grants. This would not restrict root level operators, however, for whom there are no workarounds. This interface allowed arbitrary filesystem and network (write) access as the user the OpenBao server was running as; in conjunction with allowing custom plugins or other system processes this may…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xp75-r577-cvhp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54997 Advisory: Privileged OpenBao Operator May Execute Code on the Underlying Host IDs: CVE-2025-54997, GHSA-xp75-r577-cvhp Record: https://patchnext.com/advisories/cve-2025-54997 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/openbao/openbao 2.3.2, 0.0.0-20250806194004-a14053c9679d. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/openbao/openbao: affected >= 0.1.0, < 2.3.2; < 0.0.0-20250806194004-a14053c9679d; fixed in 2.3.2, 0.0.0-20250806194004-a14053c9679d ## Suggested inspection (read-only) - Go github.com/openbao/openbao: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/openbao/openbao. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xp75-r577-cvhp (GitHub-reviewed advisory GHSA-xp75-r577-cvhp lists affected ranges: Go github.com/openbao/openbao >=0.1.0 =0 <0.0.0-20250806194004-a14053c9679d) Commands are suggestions: review each one before running it.
Loading voting…