Skip to content

← Actionable
Critical, CVSS 9.3amended

@akoskm/create-mcp-server-stdio is vulnerable to MCP Server Command Injection through exec API

CVE-2025-54994GHSA-3ch2-jxxc-v4xf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@akoskm/create-mcp-server-stdio 0.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-54994: 1.34% estimated exploitation activity in the next 30 days; percentile 71.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Command Injection in MCP Server The MCP Server at https://github.com/akoskm/create-mcp-server-stdio is written in a way that is vulnerable to command injection vulnerability attacks as part of some of its MCP Server tool definition and implementation. Vulnerable tool The MCP Server exposes the tool which-app-on-port which relies on Node.js child process API exec which is an unsafe and vulnerable API if concatenated with untrusted user input. Vulnerable line of code: https://github.com/akoskm/create-mcp-server-stdio/blob/main/src/index.ts#L24-L40 Exploitation When LLMs are tricked through prompt injection (and other techniques and attack vectors) to call the tool with input that uses special shell characters such as ; rm -rf /tmp;

(be careful actually executing this payload) and other payload variations, the full command-line text will be interepted by the shell and result in other commands except of ps executing on the host running the MCP Server. Reference example from prior…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3ch2-jxxc-v4xf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3ch2-jxxc-v4xf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54994

Advisory: @akoskm/create-mcp-server-stdio is vulnerable to MCP Server Command Injection through `exec` API
IDs: CVE-2025-54994, GHSA-3ch2-jxxc-v4xf
Record: https://patchnext.com/advisories/cve-2025-54994 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @akoskm/create-mcp-server-stdio 0.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @akoskm/create-mcp-server-stdio: affected < 0.0.13; fixed in 0.0.13

## Suggested inspection (read-only)
- `npm ls @akoskm/create-mcp-server-stdio --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @akoskm/create-mcp-server-stdio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3ch2-jxxc-v4xf (OSV record GHSA-3ch2-jxxc-v4xf lists affected ranges: npm @akoskm/create-mcp-server-stdio >=0 <0.0.13 (fixed))
- Verified: https://github.com/advisories/GHSA-3ch2-jxxc-v4xf (GitHub-reviewed advisory GHSA-3ch2-jxxc-v4xf lists affected ranges: npm @akoskm/create-mcp-server-stdio >=0 <0.0.13)

Commands are suggestions: review each one before running it.

Loading voting…