Apache Tika XXE Vulnerability via Crafted XFA File Inside a PDF
CVE-2025-54988GHSA-p72g-pv48-7w9x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tika:tika-parsers 2.0.0-ALPHA; org.apache.tika:tika-parser-pdf-module 3.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tika:tika-parsers
- Affected
- >= 1.13, < 2.0.0-ALPHA
- Fixed in
- 2.0.0-ALPHA
Maven org.apache.tika:tika-parser-pdf-module
- Affected
- >= 1.13, < 3.2.2
- Fixed in
- 3.2.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p72g-pv48-7w9x lists affected ranges: Maven org.apache.tika:tika-parser-pdf-module >=1.13 =1.13 <2.0.0-ALPHA
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54988: 47.95% estimated exploitation activity in the next 30 days; percentile 98.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p72g-pv48-7w9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54988 Advisory: Apache Tika XXE Vulnerability via Crafted XFA File Inside a PDF IDs: CVE-2025-54988, GHSA-p72g-pv48-7w9x Record: https://patchnext.com/advisories/cve-2025-54988 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tika:tika-parsers 2.0.0-ALPHA; org.apache.tika:tika-parser-pdf-module 3.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tika:tika-parsers: affected >= 1.13, < 2.0.0-ALPHA; fixed in 2.0.0-ALPHA - Maven org.apache.tika:tika-parser-pdf-module: affected >= 1.13, < 3.2.2; fixed in 3.2.2 ## Suggested inspection (read-only) - Maven org.apache.tika:tika-parsers: check the installed version with your package manager. - Maven org.apache.tika:tika-parser-pdf-module: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tika:tika-parsers, org.apache.tika:tika-parser-pdf-module. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p72g-pv48-7w9x (GitHub-reviewed advisory GHSA-p72g-pv48-7w9x lists affected ranges: Maven org.apache.tika:tika-parser-pdf-module >=1.13 =1.13 <2.0.0-ALPHA) Commands are suggestions: review each one before running it.
Loading voting…