Skip to content

← Actionable
High, CVSS 8.8

Apache Spark: Spark History Server Code Execution Vulnerability

CVE-2025-54920GHSA-jwp6-cvj8-fw65

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.spark:spark-core_2.12

    Affected
    < 3.5.7
    Fixed in
    3.5.7
  • Maven org.apache.spark:spark-core_2.13

    Affected
    >= 4.0.0, < 4.0.1< 3.5.7
    Fixed in
    3.5.7, 4.0.1
  • Maven org.apache.spark:spark-core_2.11

    Affected
    <= 2.4.8
    Fixed in
    no fixed version recorded
  • Maven org.apache.spark:spark-core_2.9.3

    Affected
    <= 0.8.1-incubating
    Fixed in
    no fixed version recorded
  • Maven org.apache.spark:spark-core_2.10

    Affected
    <= 2.2.3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-54920: 5.42% estimated exploitation activity in the next 30 days; percentile 92.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This issue affects Apache Spark: before 3.5.7 and 4.0.1. Users are recommended to upgrade to version 3.5.7 or 4.0.1 and above, which fixes the issue. Summary Apache Spark 3.5.4 and earlier versions contain a code execution vulnerability in the Spark History Web UI due to overly permissive Jackson deserialization of event log data. This allows an attacker with access to the Spark event logs directory to inject malicious JSON payloads that trigger deserialization of arbitrary classes, enabling command execution on the host running the Spark History Server. Details The vulnerability arises because the Spark History Server uses Jackson polymorphic deserialization with @JsonTypeInfo.Id.CLASS on SparkListenerEvent objects, allowing an attacker to specify arbitrary class names in the event JSON. This behavior permits instantiating unintended classes, such as org.apache.hive.jdbc.HiveConnection, which can perform network calls or other malicious actions during deserialization. The attacker…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jwp6-cvj8-fw65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54920

Advisory: Apache Spark: Spark History Server Code Execution Vulnerability
IDs: CVE-2025-54920, GHSA-jwp6-cvj8-fw65
Record: https://patchnext.com/advisories/cve-2025-54920 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.spark:spark-core_2.12 3.5.7; org.apache.spark:spark-core_2.13 4.0.1, 3.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.spark:spark-core_2.12: affected < 3.5.7; fixed in 3.5.7
- Maven org.apache.spark:spark-core_2.13: affected >= 4.0.0, < 4.0.1; < 3.5.7; fixed in 3.5.7, 4.0.1
- Maven org.apache.spark:spark-core_2.11: affected <= 2.4.8
- Maven org.apache.spark:spark-core_2.9.3: affected <= 0.8.1-incubating
- Maven org.apache.spark:spark-core_2.10: affected <= 2.2.3

## Suggested inspection (read-only)
- Maven org.apache.spark:spark-core_2.12: check the installed version with your package manager.
- Maven org.apache.spark:spark-core_2.13: check the installed version with your package manager.
- Maven org.apache.spark:spark-core_2.11: check the installed version with your package manager.
- Maven org.apache.spark:spark-core_2.9.3: check the installed version with your package manager.
- Maven org.apache.spark:spark-core_2.10: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.spark:spark-core_2.12, org.apache.spark:spark-core_2.13, org.apache.spark:spark-core_2.11, org.apache.spark:spark-core_2.9.3, org.apache.spark:spark-core_2.10.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jwp6-cvj8-fw65 (GitHub-reviewed advisory GHSA-jwp6-cvj8-fw65 lists affected ranges: Maven org.apache.spark:spark-core_2.13 >=4.0.0 =0 =0 =0 =0 =0 <=0.8.1-incubating)

Commands are suggestions: review each one before running it.

Loading voting…