@fedify/fedify has Improper Authentication and Incorrect Authorization
CVE-2025-54888GHSA-6jcc-xgcr-q3h4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 1.8.5, 1.7.9, 1.6.8, 1.5.5, 1.4.13, 1.3.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fedify/fedify
- Affected
- < 1.3.20>= 1.4.0-dev.585, < 1.4.13>= 1.5.0-dev.636, < 1.5.5>= 1.6.0-dev.754, < 1.6.8>= 1.7.0-pr.251.885, < 1.7.9>= 1.8.0-dev.909, < 1.8.5
- Fixed in
- 1.8.5, 1.4.13, 1.7.9, 1.3.20, 1.6.8, 1.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6jcc-xgcr-q3h4 lists affected ranges: npm @fedify/fedify >=0 =1.4.0-dev.585 =1.5.0-dev.636 =1.6.0-dev.754 =1.7.0-pr.251.885 =1.8.0-dev.909 <1.8.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jcc-xgcr-q3h4 lists affected ranges: npm @fedify/fedify >=0 =1.4.0-dev.585 =1.5.0-dev.636 =1.6.0-dev.754 =1.7.0-pr.251.885 =1.8.0-dev.909 <1.8.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-54888: 0.65% estimated exploitation activity in the next 30 days; percentile 51.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authentication bypass vulnerability allows any unauthenticated attacker to impersonate any ActivityPub actor by sending forged activities signed with their own keys. Activities are processed before verifying the signing key belongs to the claimed actor, enabling complete actor impersonation across all Fedify instances Details The vulnerability exists in handleInboxInternal function in fedify/federation/handler.ts. The critical flaw is in the order of operations: 1. Line 1712: routeActivity() is called first, which processes the activity (either immediately or by adding to queue) 2. Line 1730: Authentication check (doesActorOwnKey) happens AFTER processing By the time the 401 response is returned, the malicious activity has already been processed or queued. PoC 1. Create an activity claiming to be from any actor: 2. Sign the HTTP request with attacker's key (not the victim's): 3. Send to any Fedify inbox - the activity will be processed despite the key mismatch. Impact…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6jcc-xgcr-q3h4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6jcc-xgcr-q3h4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54888 Advisory: @fedify/fedify has Improper Authentication and Incorrect Authorization IDs: CVE-2025-54888, GHSA-6jcc-xgcr-q3h4 Record: https://patchnext.com/advisories/cve-2025-54888 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 1.8.5, 1.7.9, 1.6.8, 1.5.5, 1.4.13, 1.3.20. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fedify/fedify: affected < 1.3.20; >= 1.4.0-dev.585, < 1.4.13; >= 1.5.0-dev.636, < 1.5.5; >= 1.6.0-dev.754, < 1.6.8; >= 1.7.0-pr.251.885, < 1.7.9; >= 1.8.0-dev.909, < 1.8.5; fixed in 1.8.5, 1.4.13, 1.7.9, 1.3.20, 1.6.8, 1.5.5 ## Suggested inspection (read-only) - `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fedify/fedify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6jcc-xgcr-q3h4 (OSV record GHSA-6jcc-xgcr-q3h4 lists affected ranges: npm @fedify/fedify >=0 =1.4.0-dev.585 =1.5.0-dev.636 =1.6.0-dev.754 =1.7.0-pr.251.885 =1.8.0-dev.909 <1.8.5 (fixed)) - Verified: https://github.com/advisories/GHSA-6jcc-xgcr-q3h4 (GitHub-reviewed advisory GHSA-6jcc-xgcr-q3h4 lists affected ranges: npm @fedify/fedify >=0 =1.4.0-dev.585 =1.5.0-dev.636 =1.6.0-dev.754 =1.7.0-pr.251.885 =1.8.0-dev.909 <1.8.5) Commands are suggestions: review each one before running it.
Loading voting…