Skip to content

← Actionable
High, CVSS 8.4amended

SKOPS Card.get_model happily allows arbitrary code execution

CVE-2025-54886GHSA-378x-6p4f-8jgm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (skops 0.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI skops

    Affected
    < 0.13.0
    Fixed in
    0.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-54886: 0.24% estimated exploitation activity in the next 30 days; percentile 14.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Card class of skops, used for model documentation and sharing, allows arbitrary code execution. When a file other than .zip is provided to the Card class during instantiation, the internally invoked Card.getmodel method silently falls back to joblib without warning. Unlike the .skops zip-based format, joblib permits unrestricted code execution, hence bypassing the security measures of skops and enabling the execution of malicious code. Details The Card class supports loading the model linked to the card using the getmodel method. When a .skops model is provided, it uses the load function from skops, which includes security mechanisms. The Card class also supports consistent management of the trusted list, which can be passed during instance creation. As expected, if a .skops model is provided without a trusted list and an untrusted type is encountered during loading, an error is raised. This behavior is consistent with the security principles of skops. The problem arises…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-378x-6p4f-8jgm

  2. Revision 1 · created ·

    Published from osv record GHSA-378x-6p4f-8jgm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54886

Advisory: SKOPS Card.get_model happily allows arbitrary code execution
IDs: CVE-2025-54886, GHSA-378x-6p4f-8jgm
Record: https://patchnext.com/advisories/cve-2025-54886 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: skops 0.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI skops: affected < 0.13.0; fixed in 0.13.0

## Suggested inspection (read-only)
- `python -m pip show skops`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on skops.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-378x-6p4f-8jgm (OSV record GHSA-378x-6p4f-8jgm lists affected ranges: PyPI skops >=0 <0.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-378x-6p4f-8jgm (GitHub-reviewed advisory GHSA-378x-6p4f-8jgm lists affected ranges: PyPI skops >=0 <0.13.0)

Commands are suggestions: review each one before running it.

Loading voting…