Skip to content

← Actionable
Medium, CVSS 5.3amended

Mermaid improperly sanitizes sequence diagram labels leading to XSS

CVE-2025-54881GHSA-7rqq-prvp-x9jh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.10.0, 10.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mermaid

    Affected
    >= 11.0.0-alpha.1, < 11.10.0>= 10.9.0-rc.1, < 10.9.4
    Fixed in
    10.9.4, 11.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-54881: 0.80% estimated exploitation activity in the next 30 days; percentile 56.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In the default configuration of mermaid 11.9.0, user supplied input for sequence diagram labels is passed to innerHTML during calculation of element size, causing XSS. Details Sequence diagram node labels with KaTeX delimiters are passed through calculateMathMLDimensions. This method passes the full label to innerHTML which allows allows malicious users to inject arbitrary HTML and cause XSS when mermaid-js is used in it's default configuration (with KaTeX support enabled). The vulnerability lies here: The calculateMathMLDimensions method was introduced in 5c69e5fdb004a6d0a2abe97e23d26e223a059832 two years ago, which was released in Mermaid 10.9.0. PoC Render the following diagram and observe the modified DOM. Here is a PoC on mermaid.live:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7rqq-prvp-x9jh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-7rqq-prvp-x9jh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54881

Advisory: Mermaid improperly sanitizes sequence diagram labels leading to XSS
IDs: CVE-2025-54881, GHSA-7rqq-prvp-x9jh
Record: https://patchnext.com/advisories/cve-2025-54881 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mermaid 11.10.0, 10.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mermaid: affected >= 11.0.0-alpha.1, < 11.10.0; >= 10.9.0-rc.1, < 10.9.4; fixed in 10.9.4, 11.10.0

## Suggested inspection (read-only)
- `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mermaid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7rqq-prvp-x9jh (OSV record GHSA-7rqq-prvp-x9jh lists affected ranges: npm mermaid >=11.0.0-alpha.1 =10.9.0-rc.1 <10.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-7rqq-prvp-x9jh (GitHub-reviewed advisory GHSA-7rqq-prvp-x9jh lists affected ranges: npm mermaid >=11.0.0-alpha.1 =10.9.0-rc.1 <10.9.4)

Commands are suggestions: review each one before running it.

Loading voting…