Skip to content

← Actionable
Low, CVSS 2.7

RISC Zero Underconstrained Vulnerability: Division

CVE-2025-54873GHSA-f6rc-24x4-ppxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (risc0-circuit-rv32im 3.0.0; risc0-zkvm 2.2.0; risc0-circuit-rv32im-sys 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-54873: 0.41% estimated exploitation activity in the next 30 days; percentile 35.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Two issues were found: For some inputs to signed integer division, the circuit allowed two outputs, only one of which was valid. Additionally, the result of division by zero was underconstrained. This vulnerability was identified using the Picus tool from Veridise. Impacted on-chain verifiers have already been disabled via the estop mechanism outlined in the Verifier Management Design. Mitigation We recommend all impacted users upgrade as soon as possible. Rust applications using the risc0-zkvm crate at versions < 2.2 should upgrade to version 2.2.0 or later. Smart contract applications using the official RISC Zero Verifier Router do not need to take any action: zkVM version 2.2 is active on all official routers, and version 2.1 has been disabled. Smart contract applications not using the verifier router should update their contracts to send verification calls to the 2.2 version of the verifier.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f6rc-24x4-ppxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54873

Advisory: RISC Zero Underconstrained Vulnerability: Division
IDs: CVE-2025-54873, GHSA-f6rc-24x4-ppxp
Record: https://patchnext.com/advisories/cve-2025-54873 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: risc0-circuit-rv32im 3.0.0; risc0-zkvm 2.2.0; risc0-circuit-rv32im-sys 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io risc0-circuit-rv32im: affected >= 2.0.0, < 3.0.0; fixed in 3.0.0
- crates.io risc0-zkvm: affected >= 2.0.0, < 2.2.0; fixed in 2.2.0
- crates.io risc0-circuit-rv32im-sys: affected >= 2.0.0, < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- crates.io risc0-circuit-rv32im: check the installed version with your package manager.
- crates.io risc0-zkvm: check the installed version with your package manager.
- crates.io risc0-circuit-rv32im-sys: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on risc0-circuit-rv32im, risc0-zkvm, risc0-circuit-rv32im-sys.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f6rc-24x4-ppxp (GitHub-reviewed advisory GHSA-f6rc-24x4-ppxp lists affected ranges: crates.io risc0-zkvm >=2.0.0 =2.0.0 =2.0.0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…