Apache Airflow: Connection sensitive details exposed to users with READ permissions
CVE-2025-54831GHSA-q475-2pgm-7hvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow
- Affected
- >= 3.0.3, <= 3.0.3
- Fixed in
- 3.0.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q475-2pgm-7hvp lists affected ranges: PyPI apache-airflow >=3.0.3 <3.0.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q475-2pgm-7hvp lists affected ranges: PyPI apache-airflow >=3.0.3 <=3.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-54831: 0.94% estimated exploitation activity in the next 30 days; percentile 60.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow 3 introduced a change to the handling of sensitive information in Connections. The intent was to restrict access to sensitive connection fields to Connection Editing Users, effectively applying a "write-only" model for sensitive values. In Airflow 3.0.3, this model was unintentionally violated: sensitive connection information could be viewed by users with READ permissions through both the API and the UI. This behavior also bypassed the AIRFLOWCOREHIDESENSITIVEVARCONNFIELDS configuration option. This issue does not affect Airflow 2.x, where exposing sensitive information to connection editors was the intended and documented behavior. Users of Airflow 3.0.3 are advised to upgrade Airflow to =3.0.4.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q475-2pgm-7hvp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q475-2pgm-7hvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54831 Advisory: Apache Airflow: Connection sensitive details exposed to users with READ permissions IDs: CVE-2025-54831, GHSA-q475-2pgm-7hvp Record: https://patchnext.com/advisories/cve-2025-54831 (revision 3, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow: affected >= 3.0.3, <= 3.0.3; fixed in 3.0.4 ## Suggested inspection (read-only) - `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q475-2pgm-7hvp (OSV record GHSA-q475-2pgm-7hvp lists affected ranges: PyPI apache-airflow >=3.0.3 <3.0.4 (fixed)) - Verified: https://github.com/advisories/GHSA-q475-2pgm-7hvp (GitHub-reviewed advisory GHSA-q475-2pgm-7hvp lists affected ranges: PyPI apache-airflow >=3.0.3 <=3.0.3) Commands are suggestions: review each one before running it.
Loading voting…