pyLoad CNL Blueprint allows Path Traversal through dlc_path which leads to Remote Code Execution (RCE)
CVE-2025-54802GHSA-48rp-jc79-2264
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev90), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyload-ng
- Affected
- <= 0.5.0b3.dev89
- Fixed in
- 0.5.0b3.dev90
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-48rp-jc79-2264 lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev90 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48rp-jc79-2264 lists affected ranges: PyPI pyload-ng >=0 <=0.5.0b3.dev89
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-54802: 1.29% estimated exploitation activity in the next 30 days; percentile 70.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Path Traversal in pyLoad-ng CNL Blueprint via package parameter allows Arbitrary File Write leading to Remote Code Execution (RCE) The addcrypted endpoint in pyload-ng suffers from an unsafe path construction vulnerability, allowing unauthenticated attackers to write arbitrary files outside the designated storage directory. This can be abused to overwrite critical system files, including cron jobs and systemd services, leading to privilege escalation and remote code execution as root. Details Endpoint: POST /addcrypted Issue: src/pyload/webui/app/blueprints/cnlblueprint.py Vulnerable Code PoC Decoded payload: Send crafted POST Impact The vulnerability allows unauthenticated attackers to write arbitrary files outside the intended directory via a path traversal flaw in the addcrypted endpoint in pyload-ng parameter. when exploited, it enables remote code execution as root by injecting malicious cron jobs or system files, turning a simple file upload endpoint into a full system…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-48rp-jc79-2264
- Revision 1 · created ·
Published from osv record GHSA-48rp-jc79-2264
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54802 Advisory: pyLoad CNL Blueprint allows Path Traversal through `dlc_path` which leads to Remote Code Execution (RCE) IDs: CVE-2025-54802, GHSA-48rp-jc79-2264 Record: https://patchnext.com/advisories/cve-2025-54802 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev90. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyload-ng: affected <= 0.5.0b3.dev89; fixed in 0.5.0b3.dev90 ## Suggested inspection (read-only) - `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyload-ng. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-48rp-jc79-2264 (OSV record GHSA-48rp-jc79-2264 lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev90 (fixed)) - Verified: https://github.com/advisories/GHSA-48rp-jc79-2264 (GitHub-reviewed advisory GHSA-48rp-jc79-2264 lists affected ranges: PyPI pyload-ng >=0 <=0.5.0b3.dev89) Commands are suggestions: review each one before running it.
Loading voting…