github.com/go-acme/lego/v4/acme/api does not enforce HTTPS
CVE-2025-54799GHSA-q82r-2j7m-9rv4
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/go-acme/lego/v3
- Affected
- <= 4.25.1
- Fixed in
- no fixed version recorded
Go github.com/go-acme/lego/v4
- Affected
- <= 4.25.1
- Fixed in
- 4.25.2
Go github.com/go-acme/lego
- Affected
- <= 4.25.1
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q82r-2j7m-9rv4 lists affected ranges: Go github.com/go-acme/lego >=0 =0 =0 <=4.25.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-54799: 0.24% estimated exploitation activity in the next 30 days; percentile 14.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary It was discovered that the github.com/go-acme/lego/v4/acme/api package (thus the lego library and the lego cli as well) don't enforce HTTPS when talking to CAs as an ACME client. Details Unlike the http-01 challenge which solves an ACME challenge over unencrypted HTTP, the ACME protocol requires HTTPS when a client communicates with the CA to performs ACME functions. This is stated in 6.1 of RFC 8555: https://datatracker.ietf.org/doc/html/rfc8555#section-6.1 Each ACME function is accomplished by the client sending a sequence of HTTPS requests to the server [RFC2818], carrying JSON messages [RFC8259]. Use of HTTPS is REQUIRED. Each subsection of Section 7 below describes the message formats used by the function and the order in which messages are sent. However, the library fails to enforce HTTPS both in the original discover URL (configured by the library user) and in the subsequent addresses returned by the CAs in the directory and order objects. If the library user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q82r-2j7m-9rv4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-54799 Advisory: github.com/go-acme/lego/v4/acme/api does not enforce HTTPS IDs: CVE-2025-54799, GHSA-q82r-2j7m-9rv4 Record: https://patchnext.com/advisories/cve-2025-54799 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/go-acme/lego/v4 4.25.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/go-acme/lego/v3: affected <= 4.25.1 - Go github.com/go-acme/lego/v4: affected <= 4.25.1; fixed in 4.25.2 - Go github.com/go-acme/lego: affected <= 4.25.1 ## Suggested inspection (read-only) - Go github.com/go-acme/lego/v3: check the installed version with your package manager. - Go github.com/go-acme/lego/v4: check the installed version with your package manager. - Go github.com/go-acme/lego: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/go-acme/lego/v3, github.com/go-acme/lego/v4, github.com/go-acme/lego. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q82r-2j7m-9rv4 (GitHub-reviewed advisory GHSA-q82r-2j7m-9rv4 lists affected ranges: Go github.com/go-acme/lego >=0 =0 =0 <=4.25.1) Commands are suggestions: review each one before running it.
Loading voting…