Skip to content

← Actionable
Critical, CVSS 9.4amended

@nestjs/devtools-integration: CSRF to Sandbox Escape Allows for RCE against JS Developers

CVE-2025-54782GHSA-85cg-cmq5-qjm7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nestjs/devtools-integration 0.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-54782: 47.19% estimated exploitation activity in the next 30 days; percentile 98.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A critical Remote Code Execution (RCE) vulnerability was discovered in the @nestjs/devtools-integration package. When enabled, the package exposes a local development HTTP server with an API endpoint that uses an unsafe JavaScript sandbox (safe-eval-like implementation). Due to improper sandboxing and missing cross-origin protections, any malicious website visited by a developer can execute arbitrary code on their local machine. A full blog post about how this vulnerability was uncovered can be found on Socket's blog. Details The @nestjs/devtools-integration package adds HTTP endpoints to a locally running NestJS development server. One of these endpoints, /inspector/graph/interact, accepts JSON input containing a code field and executes the provided code in a Node.js vm.runInNewContext sandbox. Key issues: 1. Unsafe Sandbox: The sandbox implementation closely resembles the abandoned safe-eval library. The Node.js vm module is explicitly documented as not providing a security…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-85cg-cmq5-qjm7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-85cg-cmq5-qjm7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54782

Advisory: @nestjs/devtools-integration: CSRF to Sandbox Escape Allows for RCE against JS Developers
IDs: CVE-2025-54782, GHSA-85cg-cmq5-qjm7
Record: https://patchnext.com/advisories/cve-2025-54782 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @nestjs/devtools-integration 0.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @nestjs/devtools-integration: affected <= 0.2.0; fixed in 0.2.1

## Suggested inspection (read-only)
- `npm ls @nestjs/devtools-integration --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @nestjs/devtools-integration.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-85cg-cmq5-qjm7 (OSV record GHSA-85cg-cmq5-qjm7 lists affected ranges: npm @nestjs/devtools-integration >=0 <0.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-85cg-cmq5-qjm7 (GitHub-reviewed advisory GHSA-85cg-cmq5-qjm7 lists affected ranges: npm @nestjs/devtools-integration >=0 <=0.2.0)

Commands are suggestions: review each one before running it.

Loading voting…