Skip to content

← Actionable
Medium, CVSS 6.5amended

LlamaIndex vulnerable to DoS attack through uncontrolled recursive JSON parsing

CVE-2025-5472GHSA-3wxx-q3gv-pvvv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.38; llama-index-core 0.12.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-5472: 0.39% estimated exploitation activity in the next 30 days; percentile 32.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The JSONReader in run-llama/llamaindex versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3wxx-q3gv-pvvv

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2025-251

  3. Revision 1 · created ·

    Published from osv record GHSA-3wxx-q3gv-pvvv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-5472

Advisory: LlamaIndex vulnerable to DoS attack through uncontrolled recursive JSON parsing
IDs: CVE-2025-5472, GHSA-3wxx-q3gv-pvvv
Record: https://patchnext.com/advisories/cve-2025-5472 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.38; llama-index-core 0.12.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index: affected >= 0.12.28, < 0.12.38; fixed in 0.12.38
- PyPI llama-index-core: affected < 0.12.38; fixed in 0.12.38

## Suggested inspection (read-only)
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index, llama-index-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3wxx-q3gv-pvvv (OSV record GHSA-3wxx-q3gv-pvvv lists affected ranges: PyPI llama-index-core >=0 <0.12.38 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-251 (OSV record PYSEC-2025-251 lists affected ranges: PyPI llama-index >=0.12.28 <0.12.38 (fixed))
- Verified: https://github.com/advisories/GHSA-3wxx-q3gv-pvvv (GitHub-reviewed advisory GHSA-3wxx-q3gv-pvvv lists affected ranges: PyPI llama-index-core >=0 <0.12.38)

Commands are suggestions: review each one before running it.

Loading voting…