Skip to content

← Actionable
Medium, CVSS 6.9amended

webfinger.js Blind SSRF Vulnerability

CVE-2025-54590GHSA-8xq3-w9fx-74rv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (webfinger.js 2.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-54590: 0.71% estimated exploitation activity in the next 30 days; percentile 53.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The lookup function takes a user address for checking accounts as a feature, however, as per the ActivityPub spec (https://www.w3.org/TR/activitypub/#security-considerations), on the security considerations section at B.3, access to Localhost services should be prevented while running in production. The library does not prevent Localhost access (neither does it prevent LAN addresses such as 192.168.x.x) , thus is not safe for use in production by ActivityPub applications. The only check for localhost is done for selecting between HTTP and HTTPS protocols, and it is done by testing for a host that starts with the string “localhost” and ends with a port. Anything else (such as “127.0.0.1” or “localhost:1234/abc”) would not be considered localhost for this test. In addition, the way that the function determines the host, makes it possible to access any path in the host, not only “/.well-known/...” paths: If the address is in the format of a user address (user@host.com), the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8xq3-w9fx-74rv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8xq3-w9fx-74rv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54590

Advisory: webfinger.js Blind SSRF Vulnerability
IDs: CVE-2025-54590, GHSA-8xq3-w9fx-74rv
Record: https://patchnext.com/advisories/cve-2025-54590 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: webfinger.js 2.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm webfinger.js: affected <= 2.8.0; fixed in 2.8.1

## Suggested inspection (read-only)
- `npm ls webfinger.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on webfinger.js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8xq3-w9fx-74rv (OSV record GHSA-8xq3-w9fx-74rv lists affected ranges: npm webfinger.js >=0 <2.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-8xq3-w9fx-74rv (GitHub-reviewed advisory GHSA-8xq3-w9fx-74rv lists affected ranges: npm webfinger.js >=0 <=2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…