Skip to content

← Actionable
High, CVSS 8.2amended

GitProxy New Branch Approval Exploit

CVE-2025-54585GHSA-39p2-8hq9-fwj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@finos/git-proxy 1.19.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N · score source
EPSS
  • CVE-2025-54585: 0.42% estimated exploitation activity in the next 30 days; percentile 36.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An attacker can exploit the way GitProxy handles new branch creation to bypass the approval of prior commits on the parent branch. Because it can greatly affect system integrity, we classify this as a High impact vulnerability. Details GitProxy checks for the 0000000000000000000000000000000000000000 hash to detect new branches. This is used to process the commit accordingly in both getDiff.ts and parsePush.ts. However, the logic can be exploited as follows: 1. Make a commit in branch a (could be main) 2. Make a new branch b from that commit 3. Make a new commit in b, then approve it/get it approved 4. Go back to a, and attempt to push this commit to the proxy The unapproved commit from a will be pushed to the remote. PoC To reproduce this vulnerability: 1. Clone the target repository and make an unapproved commit on a mainline branch (e.g. main): 2. Without approving/getting the commit approved on branch a, create a new branch b based on it: 3. Approve/get approval for the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-39p2-8hq9-fwj6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-39p2-8hq9-fwj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-54585

Advisory: GitProxy New Branch Approval Exploit
IDs: CVE-2025-54585, GHSA-39p2-8hq9-fwj6
Record: https://patchnext.com/advisories/cve-2025-54585 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @finos/git-proxy 1.19.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @finos/git-proxy: affected <= 1.19.1; fixed in 1.19.2

## Suggested inspection (read-only)
- `npm ls @finos/git-proxy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @finos/git-proxy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-39p2-8hq9-fwj6 (OSV record GHSA-39p2-8hq9-fwj6 lists affected ranges: npm @finos/git-proxy >=0 <1.19.2 (fixed))
- Verified: https://github.com/advisories/GHSA-39p2-8hq9-fwj6 (GitHub-reviewed advisory GHSA-39p2-8hq9-fwj6 lists affected ranges: npm @finos/git-proxy >=0 <=1.19.1)

Commands are suggestions: review each one before running it.

Loading voting…